summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-07-04 09:20:47 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-07-04 09:20:47 +0200
commitf5d4d4995d45baf77c176224b62e424dca037aef (patch)
tree44f83e74ca47b8e488b8a14bf9e3834006b2280f /media-sound
parentsys-devel/clang: enable py3.12 (diff)
downloadgentoo-f5d4d4995d45baf77c176224b62e424dca037aef.tar.gz
gentoo-f5d4d4995d45baf77c176224b62e424dca037aef.tar.bz2
gentoo-f5d4d4995d45baf77c176224b62e424dca037aef.zip
media-sound/musepack-tools: fixes
fixed incompatible pointers removed obsolete blocked deps scrubbed patches Closes: https://bugs.gentoo.org/931661 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/musepack-tools/files/musepack-tools-495-fixup-link-depends.patch18
-rw-r--r--media-sound/musepack-tools/files/musepack-tools-495-incompatible-pointers.patch30
-rw-r--r--media-sound/musepack-tools/files/musepack-tools-495-respect-cflags.patch6
-rw-r--r--media-sound/musepack-tools/musepack-tools-495.ebuild3
4 files changed, 31 insertions, 26 deletions
diff --git a/media-sound/musepack-tools/files/musepack-tools-495-fixup-link-depends.patch b/media-sound/musepack-tools/files/musepack-tools-495-fixup-link-depends.patch
index b62800c594a3..7dfb38cd73bd 100644
--- a/media-sound/musepack-tools/files/musepack-tools-495-fixup-link-depends.patch
+++ b/media-sound/musepack-tools/files/musepack-tools-495-fixup-link-depends.patch
@@ -9,16 +9,6 @@ In revision r491 a "Gentoo patch" was merged, entitled
It inherently clashed with revision r467, which *also* renamed the
target in question.
----
- mpc2sv8/CMakeLists.txt | 2 +-
- mpcchap/CMakeLists.txt | 2 +-
- mpccut/CMakeLists.txt | 2 +-
- mpcdec/CMakeLists.txt | 2 +-
- mpcgain/CMakeLists.txt | 4 ++--
- 5 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/mpc2sv8/CMakeLists.txt b/mpc2sv8/CMakeLists.txt
-index eea0df0..a4fe93e 100644
--- a/mpc2sv8/CMakeLists.txt
+++ b/mpc2sv8/CMakeLists.txt
@@ -13,7 +13,7 @@ endif(MSVC)
@@ -30,8 +20,6 @@ index eea0df0..a4fe93e 100644
else(SHARED)
target_link_libraries(mpc2sv8 mpcdec_static)
endif(SHARED)
-diff --git a/mpcchap/CMakeLists.txt b/mpcchap/CMakeLists.txt
-index 743d5b6..50c4ded 100644
--- a/mpcchap/CMakeLists.txt
+++ b/mpcchap/CMakeLists.txt
@@ -15,7 +15,7 @@ link_directories(${libmpc_BINARY_DIR}/libmpcenc)
@@ -43,8 +31,6 @@ index 743d5b6..50c4ded 100644
else(SHARED)
target_link_libraries(mpcchap mpcdec_static)
endif(SHARED)
-diff --git a/mpccut/CMakeLists.txt b/mpccut/CMakeLists.txt
-index 7d15ce2..2fbfb7a 100644
--- a/mpccut/CMakeLists.txt
+++ b/mpccut/CMakeLists.txt
@@ -13,7 +13,7 @@ endif(MSVC)
@@ -56,8 +42,6 @@ index 7d15ce2..2fbfb7a 100644
else(SHARED)
target_link_libraries(mpccut mpcdec_static)
endif(SHARED)
-diff --git a/mpcdec/CMakeLists.txt b/mpcdec/CMakeLists.txt
-index c95f521..a4ca38f 100644
--- a/mpcdec/CMakeLists.txt
+++ b/mpcdec/CMakeLists.txt
@@ -15,7 +15,7 @@ add_executable(mpcdec_cmd mpcdec.c)
@@ -69,8 +53,6 @@ index c95f521..a4ca38f 100644
else(SHARED)
target_link_libraries(mpcdec_cmd mpcdec_static)
endif(SHARED)
-diff --git a/mpcgain/CMakeLists.txt b/mpcgain/CMakeLists.txt
-index 5445faf..474f3b3 100644
--- a/mpcgain/CMakeLists.txt
+++ b/mpcgain/CMakeLists.txt
@@ -13,14 +13,14 @@ FIND_LIBRARY(REPLAY_GAIN_LIBRARY NAMES replaygain replaygain_static PATHS
diff --git a/media-sound/musepack-tools/files/musepack-tools-495-incompatible-pointers.patch b/media-sound/musepack-tools/files/musepack-tools-495-incompatible-pointers.patch
new file mode 100644
index 000000000000..d23b002839f6
--- /dev/null
+++ b/media-sound/musepack-tools/files/musepack-tools-495-incompatible-pointers.patch
@@ -0,0 +1,30 @@
+--- musepack-tools-495/libmpcpsy/ans.c
++++ musepack-tools-495-fixed/libmpcpsy/ans.c
+@@ -287,12 +287,12 @@
+ // for L or M, respectively
+ memset ( m->FIR_L, 0, sizeof m->FIR_L ); // reset FIR
+ memset ( m->NS_Order_L, 0, sizeof m->NS_Order_L ); // reset Flags
+- FindOptimalANS ( MaxBand, MSflag, ANSspec_L, ANSspec_M, m->NS_Order_L, m->SNR_comp_L, m->FIR_L, smr.L, smr.M, m->SCF_Index_L, Transient );
++ FindOptimalANS ( MaxBand, MSflag, ANSspec_L, ANSspec_M, m->NS_Order_L, m->SNR_comp_L, m->FIR_L, smr.L, smr.M, (const void*)m->SCF_Index_L, Transient );
+
+ // for R or S, respectively
+ memset ( m->FIR_R, 0, sizeof m->FIR_R ); // reset FIR
+ memset ( m->NS_Order_R, 0, sizeof m->NS_Order_R ); // reset Flags
+- FindOptimalANS ( MaxBand, MSflag, ANSspec_R, ANSspec_S, m->NS_Order_R, m->SNR_comp_R, m->FIR_R, smr.R, smr.S, m->SCF_Index_R, Transient );
++ FindOptimalANS ( MaxBand, MSflag, ANSspec_R, ANSspec_S, m->NS_Order_R, m->SNR_comp_R, m->FIR_R, smr.R, smr.S, (const void*)m->SCF_Index_R, Transient );
+
+ return;
+ }
+--- musepack-tools-495/mpcenc/mpcenc.h
++++ musepack-tools-495-fixed/mpcenc/mpcenc.h
+@@ -241,8 +241,8 @@
+
+ float ISNR_Schaetzer ( const float* samples, const float comp, const int res);
+ float ISNR_Schaetzer_Trans ( const float* samples, const float comp, const int res);
+-void QuantizeSubband ( unsigned int* qu_output, const float* input, const int res, float* errors, const int maxNsOrder );
+-void QuantizeSubbandWithNoiseShaping ( unsigned int* qu_output, const float* input, const int res, float* errors, const float* FIR );
++void QuantizeSubband ( mpc_int16_t* qu_output, const float* input, const int res, float* errors, const int maxNsOrder );
++void QuantizeSubbandWithNoiseShaping ( mpc_int16_t* qu_output, const float* input, const int res, float* errors, const float* FIR );
+
+ void NoiseInjectionComp ( void );
+
diff --git a/media-sound/musepack-tools/files/musepack-tools-495-respect-cflags.patch b/media-sound/musepack-tools/files/musepack-tools-495-respect-cflags.patch
index 5ed2797ab3bc..1da02c8fec8b 100644
--- a/media-sound/musepack-tools/files/musepack-tools-495-respect-cflags.patch
+++ b/media-sound/musepack-tools/files/musepack-tools-495-respect-cflags.patch
@@ -3,12 +3,6 @@ From: Eli Schwartz <eschwartz93@gmail.com>
Date: Wed, 13 Mar 2024 00:00:45 -0400
Subject: [PATCH] Respect environment CFLAGS
----
- CMakeLists.txt | 4 ----
- 1 file changed, 4 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 4d9b78f..3b09d4c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,10 +20,6 @@ endif()
diff --git a/media-sound/musepack-tools/musepack-tools-495.ebuild b/media-sound/musepack-tools/musepack-tools-495.ebuild
index 0c09918a1fbe..1ca0323298d3 100644
--- a/media-sound/musepack-tools/musepack-tools-495.ebuild
+++ b/media-sound/musepack-tools/musepack-tools-495.ebuild
@@ -22,13 +22,12 @@ DEPEND="
"
RDEPEND="
${DEPEND}
- !media-libs/libmpcdec
- !media-libs/libmpcdecsv7
"
PATCHES=(
"${FILESDIR}"/${P}-respect-cflags.patch
"${FILESDIR}"/${P}-fixup-link-depends.patch
+ "${FILESDIR}"/${P}-incompatible-pointers.patch
)
src_configure() {