summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-10-06 09:43:21 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-10-06 09:43:32 +0200
commit56abe6a85c5cecf8d175738451844b8ff733e795 (patch)
tree7e7bfdca953c9a7a658373d38bb94246ba88d640 /media-sound
parentdev-ruby/backports: drop 3.24.1 (diff)
downloadgentoo-56abe6a85c5cecf8d175738451844b8ff733e795.tar.gz
gentoo-56abe6a85c5cecf8d175738451844b8ff733e795.tar.bz2
gentoo-56abe6a85c5cecf8d175738451844b8ff733e795.zip
media-sound/ardour: bump to 8.8
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ardour/Manifest1
-rw-r--r--media-sound/ardour/ardour-8.8.ebuild199
2 files changed, 200 insertions, 0 deletions
diff --git a/media-sound/ardour/Manifest b/media-sound/ardour/Manifest
index 4d138dc00905..87cf8062e049 100644
--- a/media-sound/ardour/Manifest
+++ b/media-sound/ardour/Manifest
@@ -1,2 +1,3 @@
DIST Ardour-8.6.0.tar.bz2 17588463 BLAKE2B e8d3b603fecaf453eae9e0c2cac531a5c2d35850b282d27c25dbd22a930a6537fbbff3f1fa58f4dcc525dcc65ef8343172642d16ad473c8b80b0e373364a06cb SHA512 c4a3b6369fe1a1789ba2b5cbcfd23b6ac6b93f819b016aac2c071f1135e32826ca4f5bb99d4c3e4e1d8f91f82719ae17bcf2991eb29072c14e60f282545f934a
DIST Ardour-8.7.0.tar.bz2 17807972 BLAKE2B 9bbe4ed5c3ad62d643518881a45b71642f5ce41c8620eb4c82befcb9df1053b08b60d3683961d78825f99e3a74222404c511073491972f138edaaaea445c6961 SHA512 cd2cdc1360b01d23cd3df62ee949ecab9d5d8da5112636438c2ef8a88d188503bcd7f09f2a5d8e07460dacbc35cecd96e8edbc748adccc50b5a90375f2f742d0
+DIST Ardour-8.8.0.tar.bz2 17809437 BLAKE2B 35c1346bcaf772c02195f8aeb1451d476a14c50bd3bded845961ca2142dec5b7e31bf39ff86ccb5d8ff6a96662b364c7923313e16d9e8d3e5dc9cdb84175d14a SHA512 dc0b8724ea495df2c2df2c133c980c7c7da57f14a438d5ecdc6e3810d5e462e7347309f932287f3cc5b7dd364cd9afd35e2ef0739877454274c37505954c5424
diff --git a/media-sound/ardour/ardour-8.8.ebuild b/media-sound/ardour/ardour-8.8.ebuild
new file mode 100644
index 000000000000..d3af7b789e27
--- /dev/null
+++ b/media-sound/ardour/ardour-8.8.ebuild
@@ -0,0 +1,199 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..13} )
+PYTHON_REQ_USE='threads(+)'
+PLOCALES="ca cs de el en_GB es eu fr it ja ko nn pl pt pt_PT ru sv zh"
+inherit toolchain-funcs flag-o-matic plocale python-any-r1 waf-utils desktop xdg
+
+DESCRIPTION="Digital Audio Workstation"
+HOMEPAGE="https://ardour.org/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.ardour.org/ardour/ardour.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~loong ~x86"
+ SRC_URI="https://dev.gentoo.org/~fordfrog/distfiles/Ardour-${PV}.0.tar.bz2"
+ S="${WORKDIR}/Ardour-${PV}.0"
+fi
+
+LICENSE="GPL-2"
+SLOT="8"
+IUSE="doc jack nls phonehome pulseaudio cpu_flags_ppc_altivec cpu_flags_x86_sse cpu_flags_x86_mmx cpu_flags_x86_3dnow"
+
+RDEPEND="
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-libs/boost:=
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+ dev-libs/libxml2:2
+ media-libs/alsa-lib
+ media-libs/aubio
+ media-libs/flac:=
+ media-libs/freetype:2
+ media-libs/liblo
+ media-libs/liblrdf
+ media-libs/libsamplerate
+ media-libs/libsndfile
+ media-libs/libsoundtouch
+ media-libs/raptor:2
+ media-libs/rubberband
+ media-libs/taglib
+ media-libs/vamp-plugin-sdk
+ net-libs/libwebsockets
+ net-misc/curl
+ sys-libs/readline:0=
+ sci-libs/fftw:3.0[threads]
+ virtual/libusb:1
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ x11-libs/pango
+ jack? ( virtual/jack )
+ pulseaudio? ( media-libs/libpulse )
+ media-libs/lilv
+ media-libs/sratom
+ dev-libs/sord
+ media-libs/suil[X,gtk2]
+ media-libs/lv2"
+# !bundled-libs? ( media-sound/fluidsynth ) at least libltc is missing to be able to unbundle...
+
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( app-text/doxygen[dot] )
+ jack? ( virtual/jack )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-6.8-metadata.patch"
+)
+
+pkg_pretend() {
+ [[ $(tc-getLD) == *gold* ]] && (has_version sci-libs/fftw[openmp] || has_version sci-libs/fftw[threads]) && \
+ ewarn "Linking with gold linker might produce broken executable, see bug #733972"
+}
+
+pkg_setup() {
+ if has_version \>=dev-libs/libsigc++-2.6 ; then
+ append-cxxflags -std=c++11
+ fi
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # delete optimization flags
+ sed 's/'full-optimization\'\ :\ \\[.*'/'full-optimization\'\ :\ \'\','/' -i "${S}"/wscript || die
+
+ # handle arch
+ MARCH=$(get-flag march)
+ OPTFLAGS=""
+ if use cpu_flags_x86_sse; then
+ if [[ ${MARCH} == "i686" ]] || [[ ${MARCH} == "i486" ]]; then
+ elog "You enabled sse but use an march that does not support sse!"
+ elog "We add -msse to the flags now, but please consider switching your march in make.conf!"
+ fi
+ OPTFLAGS="sse"
+ fi
+ if use cpu_flags_x86_mmx; then
+ if [[ ${MARCH} == "i486" ]]; then
+ elog "You enabled mmx with i486 set as march! You have been warned!"
+ fi
+ OPTFLAGS="${OPTFLAGS} mmx"
+ fi
+ if use cpu_flags_x86_3dnow; then
+ OPTFLAGS="${OPTFLAGS} 3dnow"
+ fi
+ sed 's/flag_line\ =\ o.*/flag_line\ =\ \": '"${OPTFLAGS}"' just some place holders\"/' \
+ -i "${S}"/wscript || die
+ sed 's/cpu\ ==\ .*/cpu\ ==\ "LeaveMarchAsIs":/' -i "${S}"/wscript || die
+
+ # boost and shebang
+ append-flags "-lboost_system"
+ python_fix_shebang "${S}"/wscript
+ python_fix_shebang "${S}"/waf
+
+ # handle locales
+ my_lcmsg() {
+ rm -f {gtk2_ardour,gtk2_ardour/appdata,libs/ardour,libs/gtkmm2ext}/po/${1}.po
+ }
+ plocale_for_each_disabled_locale my_lcmsg
+}
+
+src_configure() {
+ # avoid bug https://bugs.gentoo.org/800067
+ local -x AS="$(tc-getCC) -c"
+
+ # -Werror=odr
+ # https://tracker.ardour.org/view.php?id=9649
+ # https://bugs.gentoo.org/917095
+ filter-lto
+
+ local backends="alsa,dummy"
+ use jack && backends+=",jack"
+ use pulseaudio && backends+=",pulseaudio"
+
+ tc-export CC CXX
+ local myconf=(
+ --configdir=/etc
+ --freedesktop
+ --noconfirm
+ --optimize
+ --no-ytk
+ --with-backends=${backends}
+ $({ use cpu_flags_ppc_altivec || use cpu_flags_x86_sse; } && \
+ echo '' || echo "--no-fpu-optimization")
+ $(usex doc "--docs" '')
+ $(usex nls '' "--no-nls")
+ $(usex phonehome '' "--no-phone-home")
+ # not possible right now --use-external-libs
+ # missing dependency: https://github.com/c4dm/qm-dsp
+ )
+
+ waf-utils_src_configure "${myconf[@]}"
+}
+
+src_compile() {
+ waf-utils_src_compile
+ use nls && waf-utils_src_compile i18n
+}
+
+src_install() {
+ local s
+
+ waf-utils_src_install
+
+ mv ${PN}.1 ${PN}${SLOT}.1 || die
+ doman ${PN}${SLOT}.1
+
+ for s in 16 22 32 48 256 512; do
+ newicon -s ${s} gtk2_ardour/resources/Ardour-icon_${s}px.png ardour${SLOT}.png
+ done
+
+ # the build system still installs ardour6.png files so we get rid of those to not conflict with ardour:6
+ find "${D}/usr/share/icons/" -name ardour6.png -delete
+
+ sed -i \
+ -e "s/\(^Name=\).*/\1Ardour ${SLOT}/" \
+ -e 's/;AudioEditing;/;X-AudioEditing;/' \
+ build/gtk2_ardour/ardour${SLOT}.desktop || die
+ domenu build/gtk2_ardour/ardour${SLOT}.desktop
+
+ insinto /usr/share/mime/packages
+ newins build/gtk2_ardour/ardour.xml ardour${SLOT}.xml
+ rm "${D}/usr/share/mime/packages/ardour.xml" || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "Please do _not_ report problems with the package to ${PN} upstream."
+ elog "If you think you've found a bug, check the upstream binary package"
+ elog "before you report anything to upstream."
+}