summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-06-16 09:52:25 +0200
committerPacho Ramos <pacho@gentoo.org>2024-06-16 09:53:08 +0200
commit547171aaf81ae848bb804f2fed2774576ae1137f (patch)
tree1dff10f8c3798a96dda548f5161df1cf8ca57859 /media-sound
parentmedia-sound/bluez-alsa: add 4.2.0 (diff)
downloadgentoo-547171aaf81ae848bb804f2fed2774576ae1137f.tar.gz
gentoo-547171aaf81ae848bb804f2fed2774576ae1137f.tar.bz2
gentoo-547171aaf81ae848bb804f2fed2774576ae1137f.zip
media-sound/bluez-alsa: Sync live ebuild
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/bluez-alsa/bluez-alsa-9999.ebuild42
1 files changed, 26 insertions, 16 deletions
diff --git a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
index 0bea02fbc86b..188dc69cbacd 100644
--- a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
+++ b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools bash-completion-r1 multilib-minimal systemd
+inherit autotools bash-completion-r1 multilib-minimal readme.gentoo-r1 systemd
DESCRIPTION="Bluetooth Audio ALSA Backend"
HOMEPAGE="https://github.com/Arkq/bluez-alsa"
@@ -17,27 +17,29 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="aac aptx debug hcitop lame ldac man mpg123 ofono static-libs systemd test unwind upower"
+IUSE="aac aptx debug hcitop lame ldac liblc3 man mpg123 ofono static-libs systemd test unwind upower"
+
RESTRICT="!test? ( test )"
# bluez-alsa does not directly link to upower but
# is using the upower interface via dbus calls.
RDEPEND="
- >=dev-libs/glib-2.32[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.58.2[${MULTILIB_USEDEP}]
>=media-libs/alsa-lib-1.1.2[${MULTILIB_USEDEP}]
- >=media-libs/sbc-1.2[${MULTILIB_USEDEP}]
- >=net-wireless/bluez-5.0[${MULTILIB_USEDEP}]
+ >=media-libs/sbc-1.5[${MULTILIB_USEDEP}]
+ >=net-wireless/bluez-5.51[${MULTILIB_USEDEP}]
sys-apps/dbus[${MULTILIB_USEDEP}]
sys-libs/readline:0=
aac? ( >=media-libs/fdk-aac-0.1.1:=[${MULTILIB_USEDEP}] )
- aptx? ( media-libs/libopenaptx )
- lame? ( media-sound/lame[${MULTILIB_USEDEP}] )
- mpg123? ( media-sound/mpg123[${MULTILIB_USEDEP}] )
+ aptx? ( >=media-libs/libfreeaptx-0.1.1 )
hcitop? (
dev-libs/libbsd
sys-libs/ncurses:0=
)
+ lame? ( media-sound/lame[${MULTILIB_USEDEP}] )
ldac? ( >=media-libs/libldac-2.0.0 )
+ liblc3? ( >=media-sound/liblc3-1.0.0 )
+ mpg123? ( media-sound/mpg123[${MULTILIB_USEDEP}] )
ofono? ( net-misc/ofono )
systemd? ( sys-apps/systemd )
unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )
@@ -45,14 +47,18 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? (
- dev-libs/check
+ >=dev-libs/check-0.11.0
media-libs/libsndfile
- )"
+ )
+"
BDEPEND="
+ dev-util/gdbus-codegen
virtual/pkgconfig
man? ( virtual/pandoc )
"
+DOC_CONTENTS="Users can use this service when they are members of the \"audio\" group."
+
src_prepare() {
default
eautoreconf
@@ -62,6 +68,7 @@ multilib_src_configure() {
local myeconfargs=(
--enable-cli
--enable-faststream
+ --enable-midi
--enable-rfcomm
--with-bash-completion="$(get_bashcompdir)"
$(use_enable aac)
@@ -74,11 +81,13 @@ multilib_src_configure() {
$(use_enable test)
$(use_with systemd systemdsystemunitdir $(systemd_get_systemunitdir))
$(multilib_native_use_enable aptx)
+ $(multilib_native_use_enable aptx aptx-hd)
+ $(multilib_native_use_with aptx libfreeaptx)
$(multilib_native_use_enable hcitop)
$(multilib_native_use_enable ldac)
+ $(multilib_native_use_enable liblc3 lc3-swb)
$(multilib_native_use_enable ofono)
$(multilib_native_use_enable upower)
- $(multilib_native_use_with aptx libopenaptx)
$(use_with unwind libunwind)
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
@@ -89,14 +98,15 @@ multilib_src_install_all() {
find "${ED}" -type f -name "*.la" -delete || die
newinitd "${FILESDIR}"/bluealsa-init.d bluealsa
- newconfd "${FILESDIR}"/bluealsa-conf.d-2 bluealsa
- #systemd_dounit "${FILESDIR}"/bluealsa.service
+ newconfd "${FILESDIR}"/bluealsa-conf.d-2-r1 bluealsa
# Add config file to alsa datadir as well to preserve changes in /etc
insinto "/usr/share/alsa/alsa.conf.d/"
- doins "src/asound/20-bluealsa.conf"
+ doins "src/asound/20-bluealsa.conf.in"
+
+ readme.gentoo_create_doc
}
pkg_postinst() {
- elog "Users can use this service when they are members of the \"audio\" group."
+ readme.gentoo_print_elog
}