summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuan Liao <liaoyuan@gmail.com>2024-04-12 13:24:23 -0400
committerYixun Lan <dlan@gentoo.org>2024-04-18 11:32:59 +0000
commitff0124dce10581871aaccc6ac3c91a678598d9ec (patch)
tree107588c583fb75a7f44429fae96cc09d058a5215 /media-sound/lollypop
parentmedia-sound/lollypop: Add gnome-gitlab upstream metadata (diff)
downloadgentoo-ff0124dce10581871aaccc6ac3c91a678598d9ec.tar.gz
gentoo-ff0124dce10581871aaccc6ac3c91a678598d9ec.tar.bz2
gentoo-ff0124dce10581871aaccc6ac3c91a678598d9ec.zip
media-sound/lollypop: Add 1.4.39; enable Python 3.12
Closes: https://bugs.gentoo.org/929664 Signed-off-by: Yuan Liao <liaoyuan@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'media-sound/lollypop')
-rw-r--r--media-sound/lollypop/Manifest1
-rw-r--r--media-sound/lollypop/lollypop-1.4.39.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/media-sound/lollypop/Manifest b/media-sound/lollypop/Manifest
index 38d850355d4d..d3020726a75a 100644
--- a/media-sound/lollypop/Manifest
+++ b/media-sound/lollypop/Manifest
@@ -1,3 +1,4 @@
DIST lollypop-1.4.29.tar.xz 593980 BLAKE2B 8a3a985cb18c196665377c7c29670b98f352a86284ee8bb5af13b1017346b0b2b938dee6e53d56d0b8d98b191a64e5efd1c7126879c7017c3f10d5aa96570a39 SHA512 f81315a94cbcc726cd453d58faffe5c33ebcbdaef55a5a36d2a9dc20dec9340c2d263d935b5115148b049fca52e57c88eac36386e56f0965f22674eba26ae813
DIST lollypop-1.4.35.tar.xz 596016 BLAKE2B 6776d98d8d0da18dade3ac022ea7980e9762834ebaadae453abb0dd0f0d98298f2457d2cb18f21159e2d12d4735d3c87740b0449a090f7778b7d77ba82634e40 SHA512 8cde0db23dd011370fbcf2a32389f801d7586598bb653b921f4525af17e2eb4771a306e34a340bb8c4a1666727c4b1c3a84490f362ca3c473fb7c5b3982a644d
DIST lollypop-1.4.37.tar.xz 600812 BLAKE2B 08719d3c370332d398cb7dfc3c89128c895f89b0f5ca2b10fd85b1ef88d79ec96fbf945bbf4549e029e80726c80ccf6212e87d13b8808c08615626c6f01a4297 SHA512 9266677e8200626859793693e8cbf0e76b134fe37ff1b915841c1aebb5785eaaf1af5325c57bed78e887c98e947101103b1898d81c62cd9517b3420aebfeb685
+DIST lollypop-1.4.39.tar.xz 599984 BLAKE2B c985bda8f8ec979cc222f3860f17f2d2329bbd04f808462011f92dcca350c9b5a99af6e5aa3efc68e128946f932890d35602e1dcfbb4b86d46468dc188e5443d SHA512 5a7fe675fb70d7f4f8d4c15f8a6e4faad0f430689f3612dd72801da10174218feb444f40ee90bdcbcf39f63b0df5889c2244772f50b7389d27f3a9e969f7cdbf
diff --git a/media-sound/lollypop/lollypop-1.4.39.ebuild b/media-sound/lollypop/lollypop-1.4.39.ebuild
new file mode 100644
index 000000000000..8fb4830813fd
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.4.39.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+inherit gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+# Tarballs on adishatz.org have files from Git submodule 'subprojects/po'
+SRC_URI="https://adishatz.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+# Dependencies being checked by Meson
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ net-libs/libsoup:3.0[introspection]
+ x11-libs/gtk+:3[introspection]
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ ')
+"
+
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? (
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ )
+"
+
+RDEPEND="
+ ${DEPEND}
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser[introspection]
+ gui-libs/libhandy:1[introspection]
+ media-plugins/gst-plugins-pulse
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ meson_src_install
+ python_optimize
+ python_fix_shebang "${ED}/usr/bin"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ elog "Remember to install the necessary gst-plugins packages to read your audio files."
+ elog "You can also use the gst-plugins-meta pakcage and its USE flags."
+ elog "Lollypop now relies on yt-dlp instead of youtube-dl, since version 1.4.36."
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}