summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/gnome-music
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/gnome-music')
-rw-r--r--media-sound/gnome-music/Manifest2
-rw-r--r--media-sound/gnome-music/gnome-music-3.14.3.1.ebuild57
-rw-r--r--media-sound/gnome-music/gnome-music-3.16.1.ebuild57
-rw-r--r--media-sound/gnome-music/metadata.xml5
4 files changed, 121 insertions, 0 deletions
diff --git a/media-sound/gnome-music/Manifest b/media-sound/gnome-music/Manifest
new file mode 100644
index 000000000000..6c2cca991663
--- /dev/null
+++ b/media-sound/gnome-music/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-music-3.14.3.1.tar.xz 1466232 SHA256 9bf614cd790bc7abebe56c65f3acae56c90ea5488f97a41a8ef70bcbce42604a SHA512 ce394fdd6701f5da2b1ac1bf9ca66de706a335ac5022466260a4e5a76646a062f7b48cf27207baea37c29805b234fe0fabe34fe47cea33009b27dbc5aec54e9b WHIRLPOOL 0672023af6dc95da76c78030bfb88c3f74ae127c69715cfc624d1391c5a651808a32203e6a7e20e6408977f610c23c3153ca71616fde21b3dfb290605cf98c35
+DIST gnome-music-3.16.1.tar.xz 1477652 SHA256 116945d87fbac6aea2aedfa8e6a98bef720675916a0a6e9ae21aa83d450ad2df SHA512 dfc65d4d951fa9e87b9969b9a4c8affe467770ac37f8bf2027135b26668b099217a467cec6747f16f9cfed04f2403b13923bcd59c2548a9a22f4090adef7e2c2 WHIRLPOOL 9b9af3cdc935189a4aafbe475a1da8481389ddf70495c80a1d0834df370d3b9e195526152837638e2b29023e9734acea6ffed0f5f903b9865d3e26d25b596977
diff --git a/media-sound/gnome-music/gnome-music-3.14.3.1.ebuild b/media-sound/gnome-music/gnome-music-3.14.3.1.ebuild
new file mode 100644
index 000000000000..5a4efb77a8fe
--- /dev/null
+++ b/media-sound/gnome-music/gnome-music-3.14.3.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Music management for Gnome"
+HOMEPAGE="http://wiki.gnome.org/Apps/Music"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="amd64 x86"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.28:2
+ >=dev-libs/gobject-introspection-1.35.9
+ >=media-libs/grilo-0.2.6:0.2[introspection]
+ media-libs/libmediaart:1.0
+ >=x11-libs/gtk+-3.13.2:3[introspection]
+"
+# xdg-user-dirs-update needs to be there to create needed dirs
+# https://bugzilla.gnome.org/show_bug.cgi?id=731613
+RDEPEND="${COMMON_DEPEND}
+ app-misc/tracker[introspection(+)]
+ || (
+ app-misc/tracker[gstreamer]
+ app-misc/tracker[ffmpeg]
+ )
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/grilo-plugins:0.2[tracker]
+ x11-misc/xdg-user-dirs
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.26
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure ITSTOOL="$(type -P true)"
+}
+
+src_install() {
+ gnome2_src_install
+ python_fix_shebang "${ED}"
+}
diff --git a/media-sound/gnome-music/gnome-music-3.16.1.ebuild b/media-sound/gnome-music/gnome-music-3.16.1.ebuild
new file mode 100644
index 000000000000..a538d71c16f2
--- /dev/null
+++ b/media-sound/gnome-music/gnome-music-3.16.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Music management for Gnome"
+HOMEPAGE="http://wiki.gnome.org/Apps/Music"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.28:2
+ >=dev-libs/gobject-introspection-1.35.9:=
+ >=media-libs/grilo-0.2.6:0.2[introspection]
+ media-libs/libmediaart:2.0
+ >=x11-libs/gtk+-3.13.2:3[introspection]
+"
+# xdg-user-dirs-update needs to be there to create needed dirs
+# https://bugzilla.gnome.org/show_bug.cgi?id=731613
+RDEPEND="${COMMON_DEPEND}
+ app-misc/tracker[introspection(+)]
+ || (
+ app-misc/tracker[gstreamer]
+ app-misc/tracker[ffmpeg]
+ )
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/grilo-plugins:0.2[tracker]
+ x11-misc/xdg-user-dirs
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.26
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure ITSTOOL="$(type -P true)"
+}
+
+src_install() {
+ gnome2_src_install
+ python_fix_shebang "${ED}"
+}
diff --git a/media-sound/gnome-music/metadata.xml b/media-sound/gnome-music/metadata.xml
new file mode 100644
index 000000000000..6e0e2ecb48ca
--- /dev/null
+++ b/media-sound/gnome-music/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+</pkgmetadata>