summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2017-12-16 07:10:33 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2017-12-16 07:10:33 +0100
commite40eb61257942c08faad8c5142440de201037c83 (patch)
tree03ca948e81c4da9123e9691552ee1d5d897ba55b /media-radio/xwxapt
parentapp-text/getxbook: bump to 1.2 (diff)
downloadgentoo-e40eb61257942c08faad8c5142440de201037c83.tar.gz
gentoo-e40eb61257942c08faad8c5142440de201037c83.tar.bz2
gentoo-e40eb61257942c08faad8c5142440de201037c83.zip
media-radio/xwxapt: Version bump
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'media-radio/xwxapt')
-rw-r--r--media-radio/xwxapt/Manifest1
-rw-r--r--media-radio/xwxapt/xwxapt-3.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/media-radio/xwxapt/Manifest b/media-radio/xwxapt/Manifest
index 3356b9d4818c..8b0f85321a09 100644
--- a/media-radio/xwxapt/Manifest
+++ b/media-radio/xwxapt/Manifest
@@ -2,3 +2,4 @@ DIST xwxapt-2.4.tar.bz2 149636 BLAKE2B 0fade13e09c473c67061867e367caf2e7d5604e91
DIST xwxapt-2.7.tar.bz2 168160 BLAKE2B 92d7d2ee8d2cc65b863f085864f961be19a02c4f852920d092ea9192184ca8b34316f0440d2d13b7efcee3304a48cd2e737f7ae2c97ce2fc3cdfe77fd215b417 SHA512 591e471c79a67c80d756394068fb8fab14292460f771978dcbfada2501dde648eab5d30573dbfaa328f66f20a473aa504bbece0bc6dd5cf797087bed569f953c
DIST xwxapt-2.9.tar.bz2 170003 BLAKE2B 07cba4ebf54b56c5f6f547448dc01eb6cc5a11e486179dc8a90981dd7e2bb869a725237a9fd5444c134b95ef34babc4338fd746b956dbe42173843b494e26045 SHA512 7477d93dfe91bc09e6ff0d3e0736b0ca66c06e9fc8f9956660c54cf6e052ff10a98010223834eab0cb353cd498ee5bbd35aaca2e8517ec95fe4991058faf98c4
DIST xwxapt-3.1.tar.bz2 258794 BLAKE2B 9a78f66a03095da209575096206e440149f329cce7be0e887704da9ef95c593e07c20107703744cfeae801e1afda94e42e312f3be788af6455d44b65c15bccb5 SHA512 68e332ddd50567181d0d8e36d1466adf7baab85670d94a92cbda478c7e61bc1bac547062b8c4ec34cbf2e832919ad76002423360c7c804525a1436ce7acb7ba9
+DIST xwxapt-3.2.tar.bz2 258901 BLAKE2B 4e82c8c21d43f9407c38699b275c690cce80555e5a738b0d22f20e32cf6586f078ba84563c4b92ebdfcc8714b24128e3f142b432e38b62cdb619976234b024fc SHA512 46adcbabaf46d0a91b5284d8171d94777846dabce62cdf36df785d9e6f94fa3df987e3b7cce636d96aed6b3cffb9b5e295dc4d46b7bc3bd209acf896c8c45858
diff --git a/media-radio/xwxapt/xwxapt-3.2.ebuild b/media-radio/xwxapt/xwxapt-3.2.ebuild
new file mode 100644
index 000000000000..16d6f5224ef3
--- /dev/null
+++ b/media-radio/xwxapt/xwxapt-3.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="GTK+ linux weather satellite APT image decoder software"
+HOMEPAGE="http://www.qsl.net/5b4az/pages/apt.html"
+SRC_URI="http://www.qsl.net/5b4az/pkg/apt/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ net-wireless/rtl-sdr
+ media-libs/alsa-lib
+ dev-libs/glib:2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+HTML_DOCS="doc/xwxapt.html"
+
+src_prepare() {
+ eapply_user
+ # suppress -Weverything flag
+ sed -i -e "s/= -Weverything/= /" src/Makefile.am || die
+ # create missing mkinstalldir and prepare package
+ glib-gettextize --force --copy || die "gettextize failed"
+ eautoreconf
+}
+
+src_install() {
+ default
+ insinto /usr/share/${PN}
+ doins xwxapt/xwxaptrc
+ doins xwxapt/xwxapt.glade
+ dodir /usr/share/${PN}/images /usr/share/${PN}/records
+}
+
+pkg_postinst() {
+ einfo "You must copy the /usr/share/xwxapt directory into your home directory"
+ einfo "and configure the contained xwxaptrc file before starting the program"
+ ewarn
+ ewarn "If you just upgraded from <=xwxapt-3 do not miss to check"
+ ewarn "for changes there"
+}