summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrahmajit das <listout@protonmail.com>2023-01-14 15:33:03 +0000
committerSam James <sam@gentoo.org>2023-01-14 15:48:57 +0000
commit54d62a96059442ae89824938323f26d10daaae63 (patch)
tree687e7be8c482a43d6e312373db416e5eccadc190 /media-plugins/gst-plugins-gtk
parentmedia-plugins/gst-plugins-gdkpixbuf: add 1.20.5 (diff)
downloadgentoo-54d62a96059442ae89824938323f26d10daaae63.tar.gz
gentoo-54d62a96059442ae89824938323f26d10daaae63.tar.bz2
gentoo-54d62a96059442ae89824938323f26d10daaae63.zip
media-plugins/gst-plugins-gtk: add 1.20.5
Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: brahmajit das <listout@protonmail.com>
Diffstat (limited to 'media-plugins/gst-plugins-gtk')
-rw-r--r--media-plugins/gst-plugins-gtk/Manifest1
-rw-r--r--media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.20.5.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-gtk/Manifest b/media-plugins/gst-plugins-gtk/Manifest
index 55b92623fcb3..baa73aa4d7aa 100644
--- a/media-plugins/gst-plugins-gtk/Manifest
+++ b/media-plugins/gst-plugins-gtk/Manifest
@@ -1,2 +1,3 @@
DIST gst-plugins-good-1.20.3.tar.xz 3417252 BLAKE2B 5f288541598d2c308fbb1d5e36e54e8dd4c6e9d7dd71f41b778fbdfe883ed48e8d13fa53d05518cc671de029d804f7dc1d93396de9d199d45ec131230926d33c SHA512 98bb2dd428edaa1a5846fb47b1f42a1e99541faf05cdb0fb632d4a1a1e4fb2c1f9d1229bf0aa2ddcbce139533e9fd51f8f9a1175cd8a8729c5179750ca84afa1
DIST gst-plugins-good-1.20.4.tar.xz 3424532 BLAKE2B 2b9fa0227c13c6a81a91b4d337c3d52d6e8bd63d04710ee6bc45ec7b70de3f35c57148786356e08a253b1bbc9473411d9b0f1346433396e2403680690823c06f SHA512 d1a1d3a161fc33ecfae2b1336391571210511926a5017ea512a0bef7ab3577fb98326a96b6c5a2ffb48c8e2c7c3bf8e957e489edd0cf44e8ed8518656768c7ce
+DIST gst-plugins-good-1.20.5.tar.xz 3439904 BLAKE2B 682f8577ad048d5db5a3517fa2d3615ea902507b9aedf45da9b12e77d993e2200fd85014fd0ed9a602dfae2a1cfc420158d7d309a4b4106ac1e7b3165ef73ec9 SHA512 d8a4f4605f1da9199a6fa3cde065f5d4c550772cf085e9e05ed5ff6e44b0375d72f473a9c73346ce329f924a0b58e386358f5045ac0bee767117ef28a9f1b394
diff --git a/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.20.5.ebuild b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.20.5.ebuild
new file mode 100644
index 000000000000..55190e123f56
--- /dev/null
+++ b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.20.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE=gst-plugins-good
+
+inherit gstreamer-meson
+
+DESCRIPTION="Video sink plugin for GStreamer that renders to a GtkWidget"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+egl gles2 +opengl wayland +X" # Keep default IUSE mirrored with gst-plugins-base
+# egl, wayland and X only matters if gst-plugins-base is built with USE=opengl and/or USE=gles2
+# We mirror egl/gles2/opengl/wayland/X due to automagic detection from gstreamer-gl.pc variables;
+# we don't care about matching egl/wayland/X if both opengl and gles2 are disabled here and on
+# gst-plugins-base, but no way to express that.
+
+# We only need gtk+ matching backend flags when GL is enabled
+GL_DEPS="
+ >=x11-libs/gtk+-3.15:3[X?,wayland?,${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl=,gles2=,opengl=,wayland=,X=]
+ >=x11-libs/gtk+-3.15:3[${MULTILIB_USEDEP}]
+ gles2? ( ${GL_DEPS} )
+ opengl? ( ${GL_DEPS} )
+
+ !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}"
+
+GST_PLUGINS_ENABLED="gtk3"