summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2024-03-25 10:36:17 +0200
committerMart Raudsepp <leio@gentoo.org>2024-04-01 22:53:34 +0300
commit5c72e37ce479b06af6da2eeb58767d95c87c96c1 (patch)
treeb23993137cd80416b2ef20ed667ecdbdb61defa3 /media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.22.11.ebuild
parentmedia-plugins/gst-plugins-gdkpixbuf: add 1.22.11, EAPI-8 (diff)
downloadgentoo-5c72e37ce479b06af6da2eeb58767d95c87c96c1.tar.gz
gentoo-5c72e37ce479b06af6da2eeb58767d95c87c96c1.tar.bz2
gentoo-5c72e37ce479b06af6da2eeb58767d95c87c96c1.zip
media-plugins/gst-plugins-gtk: add 1.22.11, EAPI-8
Closes: https://bugs.gentoo.org/866926 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.22.11.ebuild')
-rw-r--r--media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.22.11.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.22.11.ebuild b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.22.11.ebuild
new file mode 100644
index 000000000000..d9d2863dcf13
--- /dev/null
+++ b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.22.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GST_ORG_MODULE=gst-plugins-good
+
+inherit gstreamer-meson
+
+DESCRIPTION="Video sink plugin for GStreamer that renders to a GtkWidget"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+egl +gles2 opengl wayland +X" # Keep default IUSE mirrored with gst-plugins-base
+# egl, wayland and X only matters if gst-plugins-base is built with USE=opengl and/or USE=gles2
+# We mirror egl/gles2/opengl/wayland/X due to automagic detection from gstreamer-gl.pc variables;
+# we don't care about matching egl/wayland/X if both opengl and gles2 are disabled here and on
+# gst-plugins-base, but no way to express that.
+
+# We only need gtk+ matching backend flags when GL is enabled
+GL_DEPS="
+ >=x11-libs/gtk+-3.15:3[X?,wayland?,${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl=,gles2=,opengl=,wayland=,X=]
+ >=x11-libs/gtk+-3.15:3[${MULTILIB_USEDEP}]
+ gles2? ( ${GL_DEPS} )
+ opengl? ( ${GL_DEPS} )
+"
+DEPEND="${RDEPEND}"
+
+GST_PLUGINS_ENABLED="gtk3"