summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-21 12:09:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-29 14:03:42 +0100
commitce86df7eb9cdd27b8da28b84541ed0894fac4b53 (patch)
tree3924362d6b5210d43d0502e02ac8f34b776b09c9 /media-libs
parentkde5.eclass: Switch to cmake.eclass (diff)
downloadgentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.tar.gz
gentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.tar.bz2
gentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.zip
*/*: Switch kde proj packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/liblastfm/liblastfm-1.1.0_pre20150206.ebuild4
-rw-r--r--media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild4
-rw-r--r--media-libs/qt-gstreamer/qt-gstreamer-1.2.0-r4.ebuild4
-rw-r--r--media-libs/taglib-extras/taglib-extras-1.0.1-r1.ebuild2
-rw-r--r--media-libs/zxing-cpp/zxing-cpp-1.0.7.ebuild2
5 files changed, 8 insertions, 8 deletions
diff --git a/media-libs/liblastfm/liblastfm-1.1.0_pre20150206.ebuild b/media-libs/liblastfm/liblastfm-1.1.0_pre20150206.ebuild
index 33eb7fb67ef5..c539e6a7b1fa 100644
--- a/media-libs/liblastfm/liblastfm-1.1.0_pre20150206.ebuild
+++ b/media-libs/liblastfm/liblastfm-1.1.0_pre20150206.ebuild
@@ -4,7 +4,7 @@
EAPI=7
COMMIT=44331654256df83bc1d3cbb271a8ce3d4c464686
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Collection of libraries to integrate Last.fm services"
HOMEPAGE="https://github.com/lastfm/liblastfm"
@@ -47,5 +47,5 @@ src_configure() {
-DBUILD_TESTS=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild b/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild
index bbbf7fcfea31..c6a9d624180f 100644
--- a/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild
+++ b/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Graphical effect and filter library by KDE"
HOMEPAGE="https://websvn.kde.org/trunk/kdesupport/qimageblitz/"
@@ -36,5 +36,5 @@ src_configure() {
)
use ppc && mycmakeargs+=( -DHAVE_ALTIVEC=$(usex altivec) )
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-libs/qt-gstreamer/qt-gstreamer-1.2.0-r4.ebuild b/media-libs/qt-gstreamer/qt-gstreamer-1.2.0-r4.ebuild
index 4adb838f82d5..11c5d26ece1f 100644
--- a/media-libs/qt-gstreamer/qt-gstreamer-1.2.0-r4.ebuild
+++ b/media-libs/qt-gstreamer/qt-gstreamer-1.2.0-r4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="C++ bindings for GStreamer with a Qt-style API"
HOMEPAGE="https://gstreamer.freedesktop.org/modules/qt-gstreamer.html"
@@ -50,5 +50,5 @@ src_configure() {
-DQTGSTREAMER_TESTS=$(usex test)
-DQT_VERSION=5
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-libs/taglib-extras/taglib-extras-1.0.1-r1.ebuild b/media-libs/taglib-extras/taglib-extras-1.0.1-r1.ebuild
index f63c5f1bc002..9c38a368dd06 100644
--- a/media-libs/taglib-extras/taglib-extras-1.0.1-r1.ebuild
+++ b/media-libs/taglib-extras/taglib-extras-1.0.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Unofficial taglib plugins maintained by the Amarok team"
HOMEPAGE="https://websvn.kde.org/trunk/kdesupport/taglib-extras/"
diff --git a/media-libs/zxing-cpp/zxing-cpp-1.0.7.ebuild b/media-libs/zxing-cpp/zxing-cpp-1.0.7.ebuild
index 1632e5bcc706..8a437d07071c 100644
--- a/media-libs/zxing-cpp/zxing-cpp-1.0.7.ebuild
+++ b/media-libs/zxing-cpp/zxing-cpp-1.0.7.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="C++ Multi-format 1D/2D barcode image processing library"
HOMEPAGE="https://github.com/nu-book/zxing-cpp"