summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-11-21 10:05:41 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-11-21 10:05:41 +0100
commitc21ff57a864bd35135f6403007a82c70859311b6 (patch)
treeca69b049509805b7ef0200ad71a6527754d0865b /media-libs
parentmedia-gfx/prusaslicer: fixes and improvements (diff)
downloadgentoo-c21ff57a864bd35135f6403007a82c70859311b6.tar.gz
gentoo-c21ff57a864bd35135f6403007a82c70859311b6.tar.bz2
gentoo-c21ff57a864bd35135f6403007a82c70859311b6.zip
media-libs/libmtp: bump to 1.1.22
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libmtp/Manifest1
-rw-r--r--media-libs/libmtp/libmtp-1.1.22.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/media-libs/libmtp/Manifest b/media-libs/libmtp/Manifest
index a0ac4c9eeeee..7c66ca04809a 100644
--- a/media-libs/libmtp/Manifest
+++ b/media-libs/libmtp/Manifest
@@ -1 +1,2 @@
DIST libmtp-1.1.21.tar.gz 862703 BLAKE2B c6067d0e9c7e2410b950715d1f02243c835afacfb3eef2f250361d4075d378b2754dceadf5120c9a646413ea826f42291c530590861420f56140458558dccc8e SHA512 510f01f75de37a07c8ce54957a8fb74724538a7cfbdf1a86c201fda68573ef23fa578ff7baf2d9df938703b5776ded4ab1057c617125f3539e594bb5a1f3146f
+DIST libmtp-1.1.22.tar.gz 900914 BLAKE2B 5032cbe430bc0ff870f1a88e5b484e6fbe59fd4d7fabd842a1e982b47cd5207e799d2dc1b410b232fc58e2b0c7ba5ca99af71eaaef3beb8849e34a51cf6c3003 SHA512 97094b29073681da0c714b6c4aea2e5f35253a8d06229e60c0af46727413470e9da6be422d873449fc4dec6f9b8efce6d3edc657b9251182cc0a709859e99baa
diff --git a/media-libs/libmtp/libmtp-1.1.22.ebuild b/media-libs/libmtp/libmtp-1.1.22.ebuild
new file mode 100644
index 000000000000..850e3a37b359
--- /dev/null
+++ b/media-libs/libmtp/libmtp-1.1.22.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit udev
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/${PN}/code"
+ inherit autotools git-r3
+else
+ inherit libtool
+ SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Implementation of Microsoft's Media Transfer Protocol (MTP)"
+HOMEPAGE="https://libmtp.sourceforge.net/"
+
+LICENSE="LGPL-2.1" # LGPL-2+ and LGPL-2.1+ ?
+SLOT="0/9" # Based on SONAME of libmtp shared library
+IUSE="+crypt doc examples static-libs"
+
+RDEPEND="
+ acct-group/plugdev
+ virtual/libiconv
+ virtual/libusb:1
+ crypt? ( dev-libs/libgcrypt:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( app-text/doxygen )"
+
+DOCS=( AUTHORS README TODO )
+
+src_prepare() {
+ default
+
+ # ChangeLog says "RETIRING THIS FILE ..pause.. GIT" (Last entry from start of 2011)
+ rm ChangeLog || die
+
+ if [[ ${PV} == 9999* ]]; then
+ if [[ -e /usr/share/gettext/config.rpath ]]; then
+ cp /usr/share/gettext/config.rpath . || die
+ else
+ touch config.rpath || die # This is from upstream autogen.sh
+ fi
+ eautoreconf
+ else
+ # Needed to fix -fuse-ld=* filtering (e.g. lld)
+ # Can drop this once copyright year in libtool file included
+ # says >= 2021 (was 2014 at time of writing).
+ elibtoolize
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable crypt mtpz)
+ $(use_enable doc doxygen)
+ $(use_enable static-libs static)
+ --with-udev="${EPREFIX}$(get_udevdir)"
+ --with-udev-group=plugdev
+ --with-udev-mode=0660
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.{c,h,sh}
+ fi
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}