summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2024-02-24 14:04:04 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2024-02-24 14:13:33 +0300
commita348750f984298be2189227a2958ac19e925247d (patch)
treee4ed054a2a8497bf80fb4810a4db88179969d32a /media-libs
parentdev-python/pillow: Fix cross-compiling (again) (diff)
downloadgentoo-a348750f984298be2189227a2958ac19e925247d.tar.gz
gentoo-a348750f984298be2189227a2958ac19e925247d.tar.bz2
gentoo-a348750f984298be2189227a2958ac19e925247d.zip
media-libs/kcolorpicker: add 0.3.0
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/kcolorpicker/Manifest1
-rw-r--r--media-libs/kcolorpicker/kcolorpicker-0.3.0.ebuild40
-rw-r--r--media-libs/kcolorpicker/metadata.xml7
3 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/kcolorpicker/Manifest b/media-libs/kcolorpicker/Manifest
index 274afcdb904f..f57a68494be2 100644
--- a/media-libs/kcolorpicker/Manifest
+++ b/media-libs/kcolorpicker/Manifest
@@ -1 +1,2 @@
DIST kColorPicker-0.2.0.tar.gz 12735 BLAKE2B 39b0c80ec5b498800dd251901b0bd57c839693f071185afacefa8d5a715ff18f2297c50486d98871471c40e0904a07ff40198b548d9368937b120a1eef07929f SHA512 44f9f317ebe5dd3131a9e44071f9f5b397b0d5cceece566f3ecf19932c8e36dafe1a434e623239421bead9413f0859bc3380174d7f14843770691e4d15a956eb
+DIST kColorPicker-0.3.0.tar.gz 12998 BLAKE2B 18c8f36b3efe1fa3c4ae9fb0e9d7497393561d66287e7ce6b5139e0182ddc69866685a85f4794afb7c861fcb824bfebb4f3c4badf148b4c8aa8b88b7b3483db2 SHA512 9f370ad8de0f23116f513e14ca22cb368cb5eaea53484388ca5ca0b7abc81d5071379cb84f8128f806c9ffa051ad29a95e42d4c1d30ba93034c0ae9fd785bb8c
diff --git a/media-libs/kcolorpicker/kcolorpicker-0.3.0.ebuild b/media-libs/kcolorpicker/kcolorpicker-0.3.0.ebuild
new file mode 100644
index 000000000000..7910473385cc
--- /dev/null
+++ b/media-libs/kcolorpicker/kcolorpicker-0.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VIRTUALX_REQUIRED="test"
+inherit cmake virtualx
+
+MY_PN=kColorPicker
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Qt based color picker with popup menu"
+HOMEPAGE="https://github.com/ksnip/kColorPicker"
+SRC_URI="https://github.com/ksnip/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-qt/qtbase:6[gui,widgets]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qtbase:6[test] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ -DBUILD_WITH_QT6=ON
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx cmake_src_test
+}
diff --git a/media-libs/kcolorpicker/metadata.xml b/media-libs/kcolorpicker/metadata.xml
index b9657fa6506a..6714b2f40edc 100644
--- a/media-libs/kcolorpicker/metadata.xml
+++ b/media-libs/kcolorpicker/metadata.xml
@@ -9,8 +9,15 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
<longdescription lang="en">QToolButton with color popup menu with lets you
select a color. The popup features a color dialog button which can be
used to add custom colors to the popup menu.
</longdescription>
+ <upstream>
+ <remote-id type="github">ksnip/kColorPicker</remote-id>
+ </upstream>
</pkgmetadata>