summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2018-06-13 02:40:56 +0200
committerMatt Turner <mattst88@gentoo.org>2018-06-13 09:39:42 -0700
commit7469468af8cbb6164977129e6ec5caa4cce256e3 (patch)
tree8616d0b823cfc44637448dee8b4ca6ff5a37cb5a /media-libs
parentx11-proto: Remove (diff)
downloadgentoo-7469468af8cbb6164977129e6ec5caa4cce256e3.tar.gz
gentoo-7469468af8cbb6164977129e6ec5caa4cce256e3.tar.bz2
gentoo-7469468af8cbb6164977129e6ec5caa4cce256e3.zip
media-libs/mesa: Support unconditional enabling of drivers
... in dri_driver_enable(), gallium_enable(), vulkan_enable().
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index afa370713b0f..91b260c97967 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -351,10 +351,10 @@ multilib_src_configure() {
fi
if use gallium; then
- GALLIUM_DRIVERS+=(swrast)
+ gallium_enable -- swrast
emesonargs+=( -Dosmesa=$(usex osmesa gallium none) )
else
- DRI_DRIVERS+=(swrast)
+ dri_driver_enable -- swrast
emesonargs+=( -Dosmesa=$(usex osmesa classic none) )
fi
@@ -457,24 +457,24 @@ pkg_prerm() {
fi
}
-# $1 - VIDEO_CARDS flag
+# $1 - VIDEO_CARDS flag (check skipped for "--")
# other args - names of DRI drivers to enable
dri_driver_enable() {
- if use $1; then
+ if [[ $1 == -- ]] || use $1; then
shift
DRI_DRIVERS+=("$@")
fi
}
gallium_enable() {
- if use $1; then
+ if [[ $1 == -- ]] || use $1; then
shift
GALLIUM_DRIVERS+=("$@")
fi
}
vulkan_enable() {
- if use $1; then
+ if [[ $1 == -- ]] || use $1; then
shift
VULKAN_DRIVERS+=("$@")
fi