summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-09-24 19:12:15 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-12 12:05:58 +0300
commit52210bb93a4337b303a0097113fa159eb51cec31 (patch)
tree286a6c4b822cdb51d8257cf8e1cc2580a5fb3750 /media-libs
parentgnome-extra/nemo: requires xapp 1.8 (diff)
downloadgentoo-52210bb93a4337b303a0097113fa159eb51cec31.tar.gz
gentoo-52210bb93a4337b303a0097113fa159eb51cec31.tar.bz2
gentoo-52210bb93a4337b303a0097113fa159eb51cec31.zip
media-libs/libheif: bump to 1.9.1
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libheif/Manifest1
-rw-r--r--media-libs/libheif/libheif-1.9.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/libheif/Manifest b/media-libs/libheif/Manifest
index 1361ad581938..98ae03b7ed25 100644
--- a/media-libs/libheif/Manifest
+++ b/media-libs/libheif/Manifest
@@ -3,3 +3,4 @@ DIST libheif-1.6.1.tar.gz 1514950 BLAKE2B d658f0c408f9a09eaac890119119327bd3e9c8
DIST libheif-1.6.2.tar.gz 1515763 BLAKE2B e7a901394349bc8bbf633a0193d7a08a1cecf7e97a8ac709efb9c2e5e6da387c7fa5e8b551cecf1f67b4e7a7d06f034e64c20d7c55f9a7898c0badb79ed485f7 SHA512 41848c05d88f82827ebdd0662a1870ce8b7899f6a86ef5aa483b301176602da8e69d2c5a49b4d911bc0cac51bdab81a06fd43efae2722092cc09c02119c95f07
DIST libheif-1.7.0.tar.gz 1526096 BLAKE2B 74b8284875321781d13d17b877eb8291ecdd0fe1700f73a433d3b125a8ee6b33a326310d729e62bac9d9fecfea095f21ef590e711d550dcaac79570b3f917885 SHA512 13c95540fee13f3fba8d8a4f69886bf5563e9fa22c5cd113dbe16d20670b077b5961171e5f9fb0f256cc42c4650e13465c93d3fbb03013997a7fc163463e8b3a
DIST libheif-1.8.0.tar.gz 1544438 BLAKE2B 983d3675c6788f69d7839d72064ca97d7347f5b2105b489ea6834c6ca5ab3d0ad8dd9157ab9d8636d3978a308d9f1983c8e5b0d151ffd9c013c9b2c9ef059d74 SHA512 e6edf03c0baf7d55ace57b8de1cf05d3b6708a0bd58d4191599960ad3924509dd7e9528a021586012b768a5a5b253e5bab470b944a2ead45f85274842da4913a
+DIST libheif-1.9.1.tar.gz 1556450 BLAKE2B 5829afbde9c8ad8d7a2ed46e736d17e84dc6f5f2c4deccd1647c3048588fb8bdec96764a31e7801aac81d5f0a3f1c3e1474b8bd5e2d4d84236ef07478e62933e SHA512 a41ff9666877904da095c72af743b56196c75ce90deaeb1998be7eba9729a62282827e7e916e2a067489cc78e558c55fbb6d70da6a5b5281f6d2efcccbe6dbbe
diff --git a/media-libs/libheif/libheif-1.9.1.ebuild b/media-libs/libheif/libheif-1.9.1.ebuild
new file mode 100644
index 000000000000..bccbc8c86622
--- /dev/null
+++ b/media-libs/libheif/libheif-1.9.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/strukturag/libheif.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/strukturag/libheif/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="ISO/IEC 23008-12:2017 HEIF file format decoder and encoder"
+HOMEPAGE="https://github.com/strukturag/libheif"
+
+LICENSE="GPL-3"
+SLOT="0/1.9"
+IUSE="gdk-pixbuf go static-libs test +threads"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-lang/go )"
+DEPEND="
+ >=media-libs/libaom-2.0.0:=[${MULTILIB_USEDEP}]
+ media-libs/libde265:=[${MULTILIB_USEDEP}]
+ media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ media-libs/x265:=[${MULTILIB_USEDEP}]
+ sys-libs/zlib:=[${MULTILIB_USEDEP}]
+ virtual/jpeg:0=[${MULTILIB_USEDEP}]
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf )
+ go? ( dev-lang/go )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i -e 's:-Werror::' configure.ac || die
+
+ eautoreconf
+
+ # prevent "stat heif-test.go: no such file or directory"
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local econf_args=(
+ $(multilib_is_native_abi && use_enable go || echo --disable-go)
+ $(use_enable gdk-pixbuf)
+ $(use_enable static-libs static)
+ $(use_enable threads multithreading)
+ )
+ ECONF_SOURCE="${S}" econf "${econf_args[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+}