summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-10 11:24:12 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-11 18:49:16 +1000
commit20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3 (patch)
tree717d375d4bc34b50cfb78c9712a992489ed8d73b /media-libs
parenteclass: update rust usedep handling; address feedback (diff)
downloadgentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.tar.gz
gentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.tar.bz2
gentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.zip
*/*: fix rust eclass usedep/mutlilib handling; inherit order
The rust eclass has been updated to directly inject a required MULTILIB_USEDEP when requested. RUST_USEDEP has been renamed to RUST_REQUIRED_USE to be consistent with other eclasses. llvm-r1 should be imported after cargo and the eclass now enables this. Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libdovi/libdovi-3.3.1-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/media-libs/libdovi/libdovi-3.3.1-r1.ebuild b/media-libs/libdovi/libdovi-3.3.1-r1.ebuild
index 6a4caf5acf88..0131e18bb74d 100644
--- a/media-libs/libdovi/libdovi-3.3.1-r1.ebuild
+++ b/media-libs/libdovi/libdovi-3.3.1-r1.ebuild
@@ -89,8 +89,9 @@ CRATES="
windows_x86_64_msvc@0.52.6
wyz@0.5.1
"
-RUST_USEDEP='${MULTILIB_USEDEP}'
-inherit multilib-minimal cargo edo rust-toolchain
+RUST_MULTILIB=1
+
+inherit cargo edo multilib-minimal rust-toolchain
DESCRIPTION="Dolby Vision metadata parsing and writing"
HOMEPAGE="https://github.com/quietvoid/dovi_tool/"