summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-22 07:43:52 +0000
committerSam James <sam@gentoo.org>2023-12-22 07:44:02 +0000
commit0f430974723f0cf6acb6857e00845a22a8bf43fe (patch)
tree1fa1a159f735ba271ffaaef1015d60042c3eb68d /media-libs
parentsys-apps/systemd-utils: Stabilize 254.7 ppc64, #919109 (diff)
downloadgentoo-0f430974723f0cf6acb6857e00845a22a8bf43fe.tar.gz
gentoo-0f430974723f0cf6acb6857e00845a22a8bf43fe.tar.bz2
gentoo-0f430974723f0cf6acb6857e00845a22a8bf43fe.zip
media-libs/libaom: add 3.8.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libaom/Manifest2
-rw-r--r--media-libs/libaom/libaom-3.8.0.ebuild144
-rw-r--r--media-libs/libaom/libaom-9999.ebuild20
3 files changed, 162 insertions, 4 deletions
diff --git a/media-libs/libaom/Manifest b/media-libs/libaom/Manifest
index c66636731d59..98fd190b1791 100644
--- a/media-libs/libaom/Manifest
+++ b/media-libs/libaom/Manifest
@@ -8,3 +8,5 @@ DIST libaom-3.7.0-testdata.tar.xz 374076136 BLAKE2B 17036f37fbb04d59b50e13e5e225
DIST libaom-3.7.0.tar.gz 5347924 BLAKE2B 2693d60f5afa810e00ab6aadcf8ca763e328bc64e47b3678eeba9993db89b25cfa0380beeff5a5938f19da74410ce83068c318cff2aea30e5fe39680ac67e937 SHA512 b763a877db26dcaddea5513825900917e55bc131bf78a83f941f1e74b534a514cb599fb64c3ac18a8202ac0a72c511dfef6eeff21dfbe59ed9816887ca3ec5f3
DIST libaom-3.7.1-testdata.tar.xz 373814716 BLAKE2B 2aecab88d36998d72ccbd170400425912404cffad0594749bd862c56ee732fa2a21898872db3898f5706459d45e13a026b6bb79ffb5ee9a6b284765ebf3cd8f6 SHA512 89a598e549602daeeb1a488303503644c4cf3f05b28706df3075c52592d3fdad13d29e56f36e571621db3d32f354af4b6978c02e9af8665f87c82f8c9918de9a
DIST libaom-3.7.1.tar.gz 5349727 BLAKE2B a5bc8aaa538353fa405520fc096459d0009348c590dc585377e53971df252bac0b5bea40b6483c8be54caa7a0e8fccd761c5b3ec0db4144becec3cc12a91a5e9 SHA512 2ac90997065fcbdfa028e09945c10cbdad405569b98e03592a46971aebb189014ebd59553589804ba0a03c386af41bfbc37dd0a12320eb0fc6c9fd03e2149ee3
+DIST libaom-3.8.0-testdata.tar.xz 426384840 BLAKE2B a195f44aa8f55e869ea613f587a101162723be643d272c08b5ac50afc9c55e2240d84f63489402482699f6c306d96116f7808f47f529ce4d0ec8149495b72b49 SHA512 18ba3468e770e274e8a1556160c8524d309d6ea80e3cca971d6858cccc5ba4f2d3764f484e19d23df83ebc50e047aa1ef6fb1a92aad90668cfee7daa95447db2
+DIST libaom-3.8.0.tar.gz 5448720 BLAKE2B 276e50c134a5a5925591cbc5c76a11383d288854bc5f4db79d97f1e4e41e74f5739ee916df127112cb678673f09aeb5dfa91f1d8696b0894923837cea991bd73 SHA512 201a3ef00c0de3f90ed2486b306b836ec3e5c891c0ea05cb4607523f084f957849d38cd1e2684c05af2a93180a1b151ccc7a99ba8d5d52a84d8cb17cb25b0e8a
diff --git a/media-libs/libaom/libaom-3.8.0.ebuild b/media-libs/libaom/libaom-3.8.0.ebuild
new file mode 100644
index 000000000000..90505353bef1
--- /dev/null
+++ b/media-libs/libaom/libaom-3.8.0.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit cmake-multilib python-any-r1
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://aomedia.googlesource.com/aom"
+else
+ # To update test data tarball, follow these steps:
+ # 1. Clone the upstream repo and check out the relevant tag,
+ # or download the release tarball
+ # 2. Regular cmake configure (options don't matter here):
+ # cd build && cmake ..
+ # 3. Set LIBAOM_TEST_DATA_PATH to the directory you want and
+ # run the "make testdata" target:
+ # LIBAOM_TEST_DATA_PATH=../libaom-3.7.1-testdata make testdata
+ # This will download the test data from the internet.
+ # 4. Create a tarball out of that directory.
+ # cd .. && tar cvaf libaom-3.7.1-testdata.tar.xz libaom-3.7.1-testdata
+ SRC_URI="
+ https://storage.googleapis.com/aom-releases/${P}.tar.gz
+ test? ( https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-testdata.tar.xz )
+ "
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DESCRIPTION="Alliance for Open Media AV1 Codec SDK"
+HOMEPAGE="https://aomedia.org https://aomedia.googlesource.com/aom/"
+
+LICENSE="BSD-2"
+SLOT="0/3"
+IUSE="big-endian doc +examples test"
+IUSE="${IUSE} cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3"
+IUSE="${IUSE} cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2"
+IUSE="${IUSE} cpu_flags_arm_crc32 cpu_flags_arm_neon cpu_flags_ppc_vsx"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ cpu_flags_x86_sse2? ( cpu_flags_x86_mmx )
+ cpu_flags_x86_ssse3? ( cpu_flags_x86_sse2 )
+"
+
+BDEPEND="${PYTHON_DEPS}
+ dev-lang/perl
+ abi_x86_32? ( dev-lang/yasm )
+ abi_x86_64? ( dev-lang/yasm )
+ abi_x86_x32? ( dev-lang/yasm )
+ doc? ( app-doc/doxygen )
+"
+
+# The PATENTS file is required to be distributed with this package, bug #682214
+DOCS=( PATENTS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.4.0-posix-c-source-ftello.patch
+ "${FILESDIR}"/${PN}-3.7.0-allow-fortify-source.patch
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CCACHE=OFF
+ -DENABLE_DOCS=$(multilib_native_usex doc ON OFF)
+ -DENABLE_EXAMPLES=$(multilib_native_usex examples ON OFF)
+ -DENABLE_NASM=OFF
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_TOOLS=ON
+ -DENABLE_WERROR=OFF
+ # https://bugs.chromium.org/p/aomedia/issues/detail?id=3487 shows
+ # that big endian detection doesn't really work otherwise.
+ -DCONFIG_BIG_ENDIAN=$(usex big-endian 1 0)
+
+ # Needs libjxl, currently unpackaged.
+ -DCONFIG_TUNE_BUTTERAUGLI=0
+
+ # arm
+ -DENABLE_NEON=$(usex cpu_flags_arm_neon ON OFF)
+ -DENABLE_ARM_CRC32=$(usex cpu_flags_arm_crc32 ON OFF)
+ # bug #917277
+ -DENABLE_NEON_DOTPROD=OFF
+ # bug #917278
+ -DENABLE_NEON_I8MM=OFF
+ # bug #920474
+ -DENABLE_SVE=OFF
+
+ # mips
+ # ENABLE_DSPR2 / ENABLE_MSA for mips
+
+ # amd64
+ -DENABLE_MMX=$(usex cpu_flags_x86_mmx ON OFF)
+ -DENABLE_SSE=$(usex cpu_flags_x86_sse ON OFF)
+ -DENABLE_SSE2=$(usex cpu_flags_x86_sse2 ON OFF)
+ -DENABLE_SSE3=$(usex cpu_flags_x86_sse3 ON OFF)
+ -DENABLE_SSSE3=$(usex cpu_flags_x86_ssse3 ON OFF)
+ -DENABLE_SSE4_1=$(usex cpu_flags_x86_sse4_1 ON OFF)
+ -DENABLE_SSE4_2=$(usex cpu_flags_x86_sse4_2 ON OFF)
+ -DENABLE_AVX=$(usex cpu_flags_x86_avx ON OFF)
+ -DENABLE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)
+
+ # ppc
+ -DENABLE_VSX=$(usex cpu_flags_ppc_vsx ON OFF)
+ )
+
+ # For 32-bit multilib builds, force some intrinsics on to work around
+ # bug #816027. libaom seems to do runtime detection for some targets
+ # at least, so this isn't an issue.
+ if ! multilib_is_native_abi && use amd64 ; then
+ mycmakeargs+=(
+ -DENABLE_SSE3=ON
+ -DENABLE_SSSE3=ON
+ )
+ fi
+
+ # On ARM32-on-ARM64, things end up failing if NEON is off, bug #835456
+ # Just force generic, given it's a niche situation.
+ # TODO: could try forcing armv7 or similar?
+ if use arm && ! use cpu_flags_arm_neon && [[ $(uname -p) == "aarch64" ]] ; then
+ ewarn "Forcing generic for arm32-on-arm64 build (bug #835456)"
+ mycmakeargs+=(
+ -DAOM_TARGET_CPU=generic
+ )
+ fi
+
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ LIBAOM_TEST_DATA_PATH="${WORKDIR}/${P}-testdata" "${BUILD_DIR}"/test_libaom || die
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi && use doc ; then
+ local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
+ fi
+
+ cmake_src_install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f \( -name "*.a" -o -name "*.la" \) -delete || die
+}
diff --git a/media-libs/libaom/libaom-9999.ebuild b/media-libs/libaom/libaom-9999.ebuild
index 342fbbcdf1db..90505353bef1 100644
--- a/media-libs/libaom/libaom-9999.ebuild
+++ b/media-libs/libaom/libaom-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake-multilib python-any-r1
if [[ ${PV} == *9999* ]]; then
@@ -36,7 +36,7 @@ SLOT="0/3"
IUSE="big-endian doc +examples test"
IUSE="${IUSE} cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3"
IUSE="${IUSE} cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2"
-IUSE="${IUSE} cpu_flags_arm_neon cpu_flags_ppc_vsx"
+IUSE="${IUSE} cpu_flags_arm_crc32 cpu_flags_arm_neon cpu_flags_ppc_vsx"
RESTRICT="!test? ( test )"
REQUIRED_USE="
@@ -76,9 +76,20 @@ multilib_src_configure() {
# Needs libjxl, currently unpackaged.
-DCONFIG_TUNE_BUTTERAUGLI=0
- # neon support is assumed to be always enabled on arm64
- -DENABLE_NEON=$(usex cpu_flags_arm_neon ON $(usex arm64 ON OFF))
+ # arm
+ -DENABLE_NEON=$(usex cpu_flags_arm_neon ON OFF)
+ -DENABLE_ARM_CRC32=$(usex cpu_flags_arm_crc32 ON OFF)
+ # bug #917277
+ -DENABLE_NEON_DOTPROD=OFF
+ # bug #917278
+ -DENABLE_NEON_I8MM=OFF
+ # bug #920474
+ -DENABLE_SVE=OFF
+
+ # mips
# ENABLE_DSPR2 / ENABLE_MSA for mips
+
+ # amd64
-DENABLE_MMX=$(usex cpu_flags_x86_mmx ON OFF)
-DENABLE_SSE=$(usex cpu_flags_x86_sse ON OFF)
-DENABLE_SSE2=$(usex cpu_flags_x86_sse2 ON OFF)
@@ -89,6 +100,7 @@ multilib_src_configure() {
-DENABLE_AVX=$(usex cpu_flags_x86_avx ON OFF)
-DENABLE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)
+ # ppc
-DENABLE_VSX=$(usex cpu_flags_ppc_vsx ON OFF)
)