summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-05-13 20:03:55 +0200
committerMichael Palimaka <kensington@gentoo.org>2019-05-15 21:48:35 +1000
commita72d36ca64d3cdc9bf12c1615a905f37451ff566 (patch)
treeccf046bbb23eb114cbbfbb7acb4df1c00dbc36b7 /media-libs/volpack
parentdev-lisp/c2ffi: Clang-based FFI wrapper generator for Common Lisp (diff)
downloadgentoo-a72d36ca64d3cdc9bf12c1615a905f37451ff566.tar.gz
gentoo-a72d36ca64d3cdc9bf12c1615a905f37451ff566.tar.bz2
gentoo-a72d36ca64d3cdc9bf12c1615a905f37451ff566.zip
media-libs/volpack: EAPI=7 update
Closes: https://bugs.gentoo.org/685882 Closes: https://github.com/gentoo/gentoo/pull/11985 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'media-libs/volpack')
-rw-r--r--media-libs/volpack/volpack-1.0_p7-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/volpack/volpack-1.0_p7-r1.ebuild b/media-libs/volpack/volpack-1.0_p7-r1.ebuild
new file mode 100644
index 000000000000..f09d6eb8b10f
--- /dev/null
+++ b/media-libs/volpack/volpack-1.0_p7-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MYP=${PN}-${PV/_p/c}
+
+DESCRIPTION="Volume rendering library"
+HOMEPAGE="http://amide.sourceforge.net/packages.html"
+SRC_URI="mirror://sourceforge/amide/${MYP}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples static-libs"
+
+DEPEND="sys-devel/m4"
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ default
+ if use doc; then
+ dodoc doc/*.pdf
+ docinto html
+ dodoc doc/*.html
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}