summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/volpack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/volpack')
-rw-r--r--media-libs/volpack/Manifest1
-rw-r--r--media-libs/volpack/metadata.xml13
-rw-r--r--media-libs/volpack/volpack-1.0_p7.ebuild40
3 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/volpack/Manifest b/media-libs/volpack/Manifest
new file mode 100644
index 000000000000..92b8d2b925b5
--- /dev/null
+++ b/media-libs/volpack/Manifest
@@ -0,0 +1 @@
+DIST volpack-1.0c7.tgz 1218492 SHA256 b82b143df479add2b3e18499537a79b1b0fa7e1cc88dff2e7481b4ee075719d2
diff --git a/media-libs/volpack/metadata.xml b/media-libs/volpack/metadata.xml
new file mode 100644
index 000000000000..32643e2e2130
--- /dev/null
+++ b/media-libs/volpack/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ The VolPack Volume Rendering Library is a portable software library for
+ volume rendering based on a new family of fast volume rendering
+ algorithms using a Shear-Warp Factorization (proceedings of SIGGRAPH94).
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">amide</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/volpack/volpack-1.0_p7.ebuild b/media-libs/volpack/volpack-1.0_p7.ebuild
new file mode 100644
index 000000000000..16bfdfb5266a
--- /dev/null
+++ b/media-libs/volpack/volpack-1.0_p7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MYP=${PN}-${PV/_p/c}
+
+DESCRIPTION="Volume rendering library"
+HOMEPAGE="http://amide.sourceforge.net/packages.html"
+SRC_URI="mirror://sourceforge/amide/${MYP}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ sys-devel/m4"
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ default
+ use doc && dodoc doc/*.pdf && dohtml doc/*.html
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+}