summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-07-29 18:27:18 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-07-29 22:00:08 +0100
commit234fe7d8314b894336813b2e5edff006beab57c8 (patch)
tree8cf158ec4dfb23f43a62288afa1ddb6ec31c6173 /media-libs/raspberrypi-userland-bin
parentmedia-libs/raspberrypi-userland-bin: set myself as maintainer (diff)
downloadgentoo-234fe7d8314b894336813b2e5edff006beab57c8.tar.gz
gentoo-234fe7d8314b894336813b2e5edff006beab57c8.tar.bz2
gentoo-234fe7d8314b894336813b2e5edff006beab57c8.zip
media-libs/raspberrypi-userland-bin: add new version 1.20190709
Cloned from existing ebuild unchanged. Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'media-libs/raspberrypi-userland-bin')
-rw-r--r--media-libs/raspberrypi-userland-bin/Manifest1
-rw-r--r--media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/raspberrypi-userland-bin/Manifest b/media-libs/raspberrypi-userland-bin/Manifest
index e85f49a46657..487bb6cedd47 100644
--- a/media-libs/raspberrypi-userland-bin/Manifest
+++ b/media-libs/raspberrypi-userland-bin/Manifest
@@ -1 +1,2 @@
DIST raspberrypi-firmware-1.20170303.tar.gz 118888867 BLAKE2B d90fc012d4371a797ed52172f0d0f94ea33901bbf10fc59f1ce0f54fbeb74a849b46dbbd4f71a73a7de655a4ed27586ee354e1535079e304bd66513452a33193 SHA512 cb0015fcaa607039db2ff40cadcfcafd0cf2ec7dd1df47f38414540fb1f86d626648bf6403989007895b0617c13ff4ec233a7b1987986224c09a8209e7732501
+DIST raspberrypi-firmware-1.20190709.tar.gz 158835870 BLAKE2B 4e63b3308adcd75f69f66966f1c927449aa8dc65211e6ca5a27dd2a0ed6ed32cc85ad42221308f4fb3a852d9f278400cfe4f723f306abe102341568408027174 SHA512 6a0610c97db47441ede8e4f8436958899f678bf065a0fbde06de7945a1ac4d5f754a0e10d928d77759ba1cbf82654d85d9cb9c91b970c3fe9590560267033522
diff --git a/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild
new file mode 100644
index 000000000000..de28e90041a5
--- /dev/null
+++ b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit multilib vcs-snapshot
+
+DESCRIPTION="Raspberry Pi userspace tools and libraries"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+MY_P="raspberrypi-firmware-${PV}"
+SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+KEYWORDS="-* ~arm"
+IUSE="+hardfp examples"
+
+RDEPEND="!media-libs/raspberrypi-userland"
+DEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+RESTRICT="binchecks"
+
+src_prepare() {
+ rm {,hardfp/}opt/vc/LICENCE || die
+}
+
+src_install() {
+ cd $(usex hardfp hardfp/ "")opt/vc || die
+
+ insinto /opt/vc
+ doins -r include
+ into /opt
+ dobin bin/*
+ dobin sbin/*
+ insopts -m 0755
+ insinto "/opt/vc/$(get_libdir)"
+ doins -r lib/*
+
+ doenvd "${FILESDIR}"/04${PN}
+
+ if use examples ; then
+ insopts -m 0644
+ insinto /usr/share/doc/${PF}/examples
+ doins -r src/hello_pi
+ fi
+}