summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/pymemphis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/pymemphis')
-rw-r--r--media-libs/pymemphis/Manifest1
-rw-r--r--media-libs/pymemphis/metadata.xml7
-rw-r--r--media-libs/pymemphis/pymemphis-0.2.1.ebuild44
3 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/pymemphis/Manifest b/media-libs/pymemphis/Manifest
new file mode 100644
index 000000000000..ff54f2ee6d90
--- /dev/null
+++ b/media-libs/pymemphis/Manifest
@@ -0,0 +1 @@
+DIST pymemphis-0.2.1.tar.gz 128848 RMD160 f1620db09a7b180badd2ae72e6add0fc6d147913 SHA1 b906cc539df7b65512e473281b88dc26c90439d8 SHA256 1d9740ebd81ad307e8941fbe0957dd17c08353610e6d7206c0dbc0099607efd4
diff --git a/media-libs/pymemphis/metadata.xml b/media-libs/pymemphis/metadata.xml
new file mode 100644
index 000000000000..dc06c49f3397
--- /dev/null
+++ b/media-libs/pymemphis/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/media-libs/pymemphis/pymemphis-0.2.1.ebuild b/media-libs/pymemphis/pymemphis-0.2.1.ebuild
new file mode 100644
index 000000000000..8b01018f722e
--- /dev/null
+++ b/media-libs/pymemphis/pymemphis-0.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+
+AT_M4DIR="build/autotools/"
+
+inherit autotools python
+
+DESCRIPTION="Python bindings for the libmemphis library"
+HOMEPAGE="http://gitorious.net/pymemphis"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2.1"
+IUSE=""
+
+RDEPEND="
+ dev-python/pycairo
+ dev-python/pygobject:2
+ media-libs/memphis"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}-mainline
+
+src_prepare() {
+ eautoreconf
+ echo "#!${EPREFIX}/bin/sh" > py-compile
+ sed 's:0.1:0.2:g' -i pymemphis.pc.in || die
+ python_src_prepare
+}
+
+src_install() {
+ python_src_install
+ python_clean_installation_image
+ dodoc AUTHORS ChangeLog README || die
+}