summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoakim Tjernlund <Joakim.Tjernlund@infinera.com>2021-03-17 00:54:12 +0100
committerSam James <sam@gentoo.org>2021-03-17 01:16:03 +0000
commitf411b6a48680122d54db515b256edcfe706973a2 (patch)
tree330f2f127a3752407347b5cebf8da37354af0ce4 /media-libs/libopenaptx
parentgames-engines/box2d: Keyword 2.4.1 ppc64, #775848 (diff)
downloadgentoo-f411b6a48680122d54db515b256edcfe706973a2.tar.gz
gentoo-f411b6a48680122d54db515b256edcfe706973a2.tar.bz2
gentoo-f411b6a48680122d54db515b256edcfe706973a2.zip
media-libs/libopenaptx: new package
* Add libopenaptx-0.2.0/9999 ebuilds Closes: https://bugs.gentoo.org/758377 Signed-off-by: Joakim Tjernlund <Joakim.Tjernlund@infinera.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/libopenaptx')
-rw-r--r--media-libs/libopenaptx/Manifest1
-rw-r--r--media-libs/libopenaptx/libopenaptx-0.2.0.ebuild39
-rw-r--r--media-libs/libopenaptx/libopenaptx-9999.ebuild39
-rw-r--r--media-libs/libopenaptx/metadata.xml8
4 files changed, 87 insertions, 0 deletions
diff --git a/media-libs/libopenaptx/Manifest b/media-libs/libopenaptx/Manifest
new file mode 100644
index 000000000000..7271834f99f6
--- /dev/null
+++ b/media-libs/libopenaptx/Manifest
@@ -0,0 +1 @@
+DIST libopenaptx-0.2.0.tar.gz 27797 BLAKE2B b178a9aaf78796c9219d9e7066ff985ce9f5dd86a6926ae22e373f2822090ad313efe04d5cf607940f1042bd27ddf5484d7e8298dfff91a8ae5596cec7ad5fa9 SHA512 d57e5084b398eec2ad49c9893baa496651c139abfb95692c834a4691bc4bb951d0b1afdd499a8b67c84b873407b584965d3a045d8ef3d9e62b3ccf45de22809a
diff --git a/media-libs/libopenaptx/libopenaptx-0.2.0.ebuild b/media-libs/libopenaptx/libopenaptx-0.2.0.ebuild
new file mode 100644
index 000000000000..7ebf9df70515
--- /dev/null
+++ b/media-libs/libopenaptx/libopenaptx-0.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Reverse-engineered aptX and aptX HD library"
+HOMEPAGE="https://github.com/pali/libopenaptx"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pali/${PN}"
+else
+ SRC_URI="https://github.com/pali/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="cpu_flags_x86_avx2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ use cpu_flags_x86_avx2 && append-cflags "-mavx2"
+
+ emake PREFIX="${EPREFIX}"/usr DESTDIR="${D}" LIBDIR=$(get_libdir) \
+ CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" ARFLAGS="$ARFLAGS -rcs" all
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}"/usr DESTDIR="${D}" LIBDIR=$(get_libdir) \
+ CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" ARFLAGS="$ARFLAGS -rcs" install
+
+ #rm static lib
+ rm -f "${D}/usr/$(get_libdir)"/libopenaptx.a || die "rm libopenaptx.a"
+}
diff --git a/media-libs/libopenaptx/libopenaptx-9999.ebuild b/media-libs/libopenaptx/libopenaptx-9999.ebuild
new file mode 100644
index 000000000000..7ebf9df70515
--- /dev/null
+++ b/media-libs/libopenaptx/libopenaptx-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Reverse-engineered aptX and aptX HD library"
+HOMEPAGE="https://github.com/pali/libopenaptx"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pali/${PN}"
+else
+ SRC_URI="https://github.com/pali/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="cpu_flags_x86_avx2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ use cpu_flags_x86_avx2 && append-cflags "-mavx2"
+
+ emake PREFIX="${EPREFIX}"/usr DESTDIR="${D}" LIBDIR=$(get_libdir) \
+ CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" ARFLAGS="$ARFLAGS -rcs" all
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}"/usr DESTDIR="${D}" LIBDIR=$(get_libdir) \
+ CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" ARFLAGS="$ARFLAGS -rcs" install
+
+ #rm static lib
+ rm -f "${D}/usr/$(get_libdir)"/libopenaptx.a || die "rm libopenaptx.a"
+}
diff --git a/media-libs/libopenaptx/metadata.xml b/media-libs/libopenaptx/metadata.xml
new file mode 100644
index 000000000000..733f9c60ae69
--- /dev/null
+++ b/media-libs/libopenaptx/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>codec@gentoo.org</email>
+ <name>Gentoo Codec Project</name>
+ </maintainer>
+</pkgmetadata>