summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro_gentoo@matoro.tk>2024-02-01 23:13:50 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-03-14 20:17:57 -0400
commitb461cba9e68deb8e8853173616ed2c02fb7d5bdb (patch)
treee230efcf5a6ec34382dedab8b9d34d34c32d3115 /media-libs/libnsgif/libnsgif-1.0.0-r1.ebuild
parentnet-im/telegram-desktop-bin: add 4.15.2 (diff)
downloadgentoo-b461cba9e68deb8e8853173616ed2c02fb7d5bdb.tar.gz
gentoo-b461cba9e68deb8e8853173616ed2c02fb7d5bdb.tar.bz2
gentoo-b461cba9e68deb8e8853173616ed2c02fb7d5bdb.zip
media-libs/libnsgif: wire up tests
Test failures are currently not fatal, so this includes a downstream patch to change that. Closes: https://github.com/gentoo/gentoo/pull/35142 Bug: https://bugs.gentoo.org/918642 Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'media-libs/libnsgif/libnsgif-1.0.0-r1.ebuild')
-rw-r--r--media-libs/libnsgif/libnsgif-1.0.0-r1.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/media-libs/libnsgif/libnsgif-1.0.0-r1.ebuild b/media-libs/libnsgif/libnsgif-1.0.0-r1.ebuild
index f088e76b8618..0b43eedea1c8 100644
--- a/media-libs/libnsgif/libnsgif-1.0.0-r1.ebuild
+++ b/media-libs/libnsgif/libnsgif-1.0.0-r1.ebuild
@@ -20,6 +20,8 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=( "${FILESDIR}/${PN}-1.0.0-make-test-failures-fatal.patch" )
+
src_prepare() {
default
sed -e '1i#pragma GCC diagnostic ignored "-Wimplicit-fallthrough"' \
@@ -35,6 +37,10 @@ src_compile() {
_emake
}
+src_test() {
+ _emake test
+}
+
src_install() {
_emake DESTDIR="${D}" install
}