summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNHOrus <jy6x2b32pie9@yahoo.com>2024-03-28 00:33:45 +0400
committerSam James <sam@gentoo.org>2024-05-08 11:42:52 +0100
commite88c6db1a899e68c63eb63fb177677aba929cb8e (patch)
tree46189055b2a9055e137099859efa33dde00fa38d /media-libs/libggi/libggi-2.2.2-r1.ebuild
parentsys-apps/intune-portal: Bump to 1.2404.23, drop old 1.2402.12 (diff)
downloadgentoo-e88c6db1a899e68c63eb63fb177677aba929cb8e.tar.gz
gentoo-e88c6db1a899e68c63eb63fb177677aba929cb8e.tar.bz2
gentoo-e88c6db1a899e68c63eb63fb177677aba929cb8e.zip
media-libs/libggi: Fix incompatible function pointer types
Closes: https://bugs.gentoo.org/880931 Signed-off-by: NHOrus <jy6x2b32pie9@yahoo.com> Closes: https://github.com/gentoo/gentoo/pull/35955 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/libggi/libggi-2.2.2-r1.ebuild')
-rw-r--r--media-libs/libggi/libggi-2.2.2-r1.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/media-libs/libggi/libggi-2.2.2-r1.ebuild b/media-libs/libggi/libggi-2.2.2-r1.ebuild
deleted file mode 100644
index 5c776bc44459..000000000000
--- a/media-libs/libggi/libggi-2.2.2-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="Provides an opaque interface to the display's acceleration function"
-HOMEPAGE="https://ibiblio.org/ggicore/packages/libggi.html"
-SRC_URI="https://downloads.sourceforge.net/ggi/${P}.src.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="3dfx aalib cpu_flags_x86_mmx debug fbcon svga vis X"
-
-RDEPEND=">=media-libs/libgii-1.0.2
- aalib? ( >=media-libs/aalib-1.2-r1 )
- svga? ( >=media-libs/svgalib-1.4.2 )
- X? (
- x11-libs/libXt
- x11-libs/libXxf86dga
- x11-libs/libXxf86vm
- )"
-DEPEND="${RDEPEND}
- X? ( x11-base/xorg-proto )"
-
-DOCS=( ChangeLog ChangeLog.1999 FAQ NEWS README )
-
-PATCHES=(
- "${FILESDIR}/${P}-slibtool.patch" # 775584
-)
-
-src_prepare() {
- default
-
- # We really don't want this
- # https://sourceforge.net/p/ggi/patches/7/
- rm -f acinclude.m4 || die
-
- eautoreconf
-}
-
-src_configure() {
- local myconf=""
-
- use svga || myconf="${myconf} --disable-svga --disable-vgagl"
-
- if use amd64 || use ppc64 || use ia64 ; then
- myconf="${myconf} --enable-64bitc"
- else
- myconf="${myconf} --disable-64bitc"
- fi
-
- econf $(use_enable 3dfx glide) \
- $(use_enable aalib aa) \
- $(use_enable debug) \
- $(use_enable cpu_flags_x86_mmx mmx) \
- $(use_enable vis) \
- $(use_with X x) \
- $(use_enable X x) \
- $(use_enable fbcon fbdev) \
- --disable-directfb \
- --disable-static \
- ${myconf}
-}
-
-src_install() {
- default
-
- docinto txt
- dodoc doc/*.txt
-
- find "${D}" -name '*.la' -delete || die
-}