summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-17 06:10:57 +0100
committerSam James <sam@gentoo.org>2023-06-17 06:40:38 +0100
commit346510d96fcfdc79f4b4448135bbf58679120f53 (patch)
tree439535b6bd3ff3bbf0872fe0ae686ef8a0f3fa90 /media-libs/gmmlib
parentdev-ruby/fakefs: drop 1.3.2 (diff)
downloadgentoo-346510d96fcfdc79f4b4448135bbf58679120f53.tar.gz
gentoo-346510d96fcfdc79f4b4448135bbf58679120f53.tar.bz2
gentoo-346510d96fcfdc79f4b4448135bbf58679120f53.zip
media-libs/gmmlib: fix build error
Closes: https://bugs.gentoo.org/908592 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/gmmlib')
-rw-r--r--media-libs/gmmlib/files/gmmlib-22.3.7_ambiguating.patch27
-rw-r--r--media-libs/gmmlib/gmmlib-22.3.7.ebuild1
2 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/gmmlib/files/gmmlib-22.3.7_ambiguating.patch b/media-libs/gmmlib/files/gmmlib-22.3.7_ambiguating.patch
new file mode 100644
index 000000000000..889573ed94a5
--- /dev/null
+++ b/media-libs/gmmlib/files/gmmlib-22.3.7_ambiguating.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/908592
+https://github.com/intel/gmmlib/issues/103
+https://github.com/intel/gmmlib/pull/104
+
+From 2526286f29d8ad3d3a5833bdc29e23e5f3300b34 Mon Sep 17 00:00:00 2001
+From: Nicolas Chauvet <kwizart@gmail.com>
+Date: Mon, 12 Jun 2023 11:49:51 +0200
+Subject: [PATCH] Fix ambiguating new declaration LockMAContextSyncMutex()
+
+This fixes https://github.com/intel/gmmlib/issues/103 introduced by
+commit 5e12695c2c "Multi-threaded fixes for GMM Context info"
+
+Signed-off-by: Nicolas Chauvet <kwizart@gmail.com>
+--- a/Source/GmmLib/inc/External/Common/GmmInfo.h
++++ b/Source/GmmLib/inc/External/Common/GmmInfo.h
+@@ -627,8 +627,8 @@ typedef struct _GMM_ADAPTER_INFO_
+ GMM_ADAPTER_INFO * GetAdapterNode(ADAPTER_BDF sBdf); // Replacement for GetAdapterIndex, now get adapter node from the linked list
+
+ // Mutexes which protect the below thread unsafe functions
+- GMM_STATUS LockMAContextSyncMutex();
+- GMM_STATUS UnLockMAContextSyncMutex();
++ GMM_STATUS GMM_STDCALL LockMAContextSyncMutex();
++ GMM_STATUS GMM_STDCALL UnLockMAContextSyncMutex();
+
+ // thread unsafe functions; these must be protected with LockMAContextSyncMutex
+ GMM_ADAPTER_INFO * GetAdapterNodeUnlocked(ADAPTER_BDF sBdf);
+
diff --git a/media-libs/gmmlib/gmmlib-22.3.7.ebuild b/media-libs/gmmlib/gmmlib-22.3.7.ebuild
index 21abbf34e428..9cd65afb169d 100644
--- a/media-libs/gmmlib/gmmlib-22.3.7.ebuild
+++ b/media-libs/gmmlib/gmmlib-22.3.7.ebuild
@@ -22,6 +22,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
"${FILESDIR}"/${PN}-20.3.2_cmake_project.patch
"${FILESDIR}"/${PN}-22.1.1_custom_cflags.patch
+ "${FILESDIR}"/${PN}-22.3.7_ambiguating.patch
)
multilib_src_configure() {