summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/flac/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/flac/files')
-rw-r--r--media-libs/flac/files/flac-1.3.0-asneeded.patch21
-rw-r--r--media-libs/flac/files/flac-1.3.0-dontbuild-examples.patch30
-rw-r--r--media-libs/flac/files/flac-1.3.0-dontbuild-tests.patch66
-rw-r--r--media-libs/flac/files/flac-1.3.1-cflags.patch23
4 files changed, 140 insertions, 0 deletions
diff --git a/media-libs/flac/files/flac-1.3.0-asneeded.patch b/media-libs/flac/files/flac-1.3.0-asneeded.patch
new file mode 100644
index 000000000000..a38b3202500a
--- /dev/null
+++ b/media-libs/flac/files/flac-1.3.0-asneeded.patch
@@ -0,0 +1,21 @@
+--- flac-1.3.0/src/flac/Makefile.am
++++ flac-1.3.0/src/flac/Makefile.am
+@@ -51,7 +51,7 @@
+ $(top_builddir)/src/share/replaygain_analysis/libreplaygain_analysis.la \
+ $(top_builddir)/src/share/replaygain_synthesis/libreplaygain_synthesis.la \
+ $(top_builddir)/src/libFLAC/libFLAC.la \
+- @LIBICONV@ \
++ @LTLIBICONV@ \
+ -lm
+
+ CLEANFILES = flac.exe
+--- flac-1.3.0/src/metaflac/Makefile.am
++++ flac-1.3.0/src/metaflac/Makefile.am
+@@ -48,6 +48,6 @@
+ $(top_builddir)/src/share/getopt/libgetopt.la \
+ $(top_builddir)/src/share/utf8/libutf8.la \
+ $(top_builddir)/src/libFLAC/libFLAC.la \
+- @LIBICONV@
++ @LTLIBICONV@
+
+ CLEANFILES = metaflac.exe
diff --git a/media-libs/flac/files/flac-1.3.0-dontbuild-examples.patch b/media-libs/flac/files/flac-1.3.0-dontbuild-examples.patch
new file mode 100644
index 000000000000..5c25dd588f2b
--- /dev/null
+++ b/media-libs/flac/files/flac-1.3.0-dontbuild-examples.patch
@@ -0,0 +1,30 @@
+--- flac-1.3.0/configure.ac
++++ flac-1.3.0/configure.ac
+@@ -319,6 +319,12 @@
+ fi
+ AC_SUBST(OGG_PACKAGE)
+
++dnl Build examples?
++AC_ARG_ENABLE(examples,
++ AS_HELP_STRING([--disable-examples], [Don't build examples during make]),,
++ enable_examples="yes")
++AM_CONDITIONAL(EXAMPLES, [test "$enable_examples" = "yes"])
++
+ dnl check for i18n(internationalization); these are from libiconv/gettext
+ AM_ICONV
+ AM_LANGINFO_CODESET
+--- flac-1.3.0/Makefile.am
++++ flac-1.3.0/Makefile.am
+@@ -31,7 +31,11 @@
+
+ ACLOCAL_AMFLAGS = -I m4
+
+-SUBDIRS = doc include m4 man src examples test build objs
++SUBDIRS = doc include m4 man src test build objs
++
++if EXAMPLES
++SUBDIRS += examples
++endif
+
+ EXTRA_DIST = \
+ COPYING.FDL \
diff --git a/media-libs/flac/files/flac-1.3.0-dontbuild-tests.patch b/media-libs/flac/files/flac-1.3.0-dontbuild-tests.patch
new file mode 100644
index 000000000000..0915a5976609
--- /dev/null
+++ b/media-libs/flac/files/flac-1.3.0-dontbuild-tests.patch
@@ -0,0 +1,66 @@
+--- flac-1.3.0/src/test_grabbag/cuesheet/Makefile.am
++++ flac-1.3.0/src/test_grabbag/cuesheet/Makefile.am
+@@ -21,7 +21,7 @@
+ test_cuesheet.vcproj
+
+ AM_CPPFLAGS = -I$(top_builddir) -I$(srcdir)/include -I$(top_srcdir)/include
+-noinst_PROGRAMS = test_cuesheet
++check_PROGRAMS = test_cuesheet
+ test_cuesheet_SOURCES = \
+ main.c
+ test_cuesheet_LDADD = \
+--- flac-1.3.0/src/test_grabbag/picture/Makefile.am
++++ flac-1.3.0/src/test_grabbag/picture/Makefile.am
+@@ -21,7 +21,7 @@
+ test_picture.vcproj
+
+ AM_CPPFLAGS = -I$(top_builddir) -I$(srcdir)/include -I$(top_srcdir)/include
+-noinst_PROGRAMS = test_picture
++check_PROGRAMS = test_picture
+ test_picture_SOURCES = \
+ main.c
+
+--- flac-1.3.0/src/test_libFLAC/Makefile.am
++++ flac-1.3.0/src/test_libFLAC/Makefile.am
+@@ -22,7 +22,7 @@
+
+ AM_CPPFLAGS = -I$(top_builddir) -I$(srcdir)/include -I$(top_srcdir)/include -I$(top_srcdir)/src/libFLAC/include
+
+-noinst_PROGRAMS = test_libFLAC
++check_PROGRAMS = test_libFLAC
+
+ if OS_IS_WINDOWS
+ win_utf8_lib = $(top_builddir)/src/share/win_utf8_io/libwin_utf8_io.la
+--- flac-1.3.0/src/test_libFLAC++/Makefile.am
++++ flac-1.3.0/src/test_libFLAC++/Makefile.am
+@@ -21,7 +21,7 @@
+ test_libFLAC++.vcproj
+
+ AM_CPPFLAGS = -I$(top_builddir) -I$(srcdir)/include -I$(top_srcdir)/include
+-noinst_PROGRAMS = test_libFLAC++
++check_PROGRAMS = test_libFLAC++
+ test_libFLAC___LDADD = \
+ $(top_builddir)/src/share/grabbag/libgrabbag.la \
+ $(top_builddir)/src/share/replaygain_analysis/libreplaygain_analysis.la \
+--- flac-1.3.0/src/test_seeking/Makefile.am
++++ flac-1.3.0/src/test_seeking/Makefile.am
+@@ -24,7 +24,7 @@
+
+ AM_CPPFLAGS = -I$(top_builddir) -I$(srcdir)/include -I$(top_srcdir)/include
+
+-noinst_PROGRAMS = test_seeking
++check_PROGRAMS = test_seeking
+ test_seeking_LDADD = \
+ $(top_builddir)/src/libFLAC/libFLAC.la
+
+--- flac-1.3.0/src/test_streams/Makefile.am
++++ flac-1.3.0/src/test_streams/Makefile.am
+@@ -21,7 +21,7 @@
+ test_streams.vcproj
+
+ AM_CPPFLAGS = -I$(top_builddir) -I$(srcdir)/include -I$(top_srcdir)/include
+-noinst_PROGRAMS = test_streams
++check_PROGRAMS = test_streams
+ test_streams_SOURCES = \
+ main.c
+
diff --git a/media-libs/flac/files/flac-1.3.1-cflags.patch b/media-libs/flac/files/flac-1.3.1-cflags.patch
new file mode 100644
index 000000000000..758e7b31c13a
--- /dev/null
+++ b/media-libs/flac/files/flac-1.3.1-cflags.patch
@@ -0,0 +1,23 @@
+--- flac-1.3.1/configure.ac
++++ flac-1.3.1/configure.ac
+@@ -348,12 +348,8 @@
+
+ if test "x$debug" = xtrue; then
+ CPPFLAGS="-DDEBUG $CPPFLAGS"
+- CFLAGS=$(echo "$CFLAGS" | sed 's/-g//')
+- CFLAGS="-g $CFLAGS"
+ else
+ CPPFLAGS="-DNDEBUG $CPPFLAGS"
+- CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//;s/-g//')
+- CFLAGS="-O3 -funroll-loops $CFLAGS"
+ fi
+
+ XIPH_GCC_VERSION
+@@ -363,7 +359,6 @@
+ CXXFLAGS="$CXXFLAGS -Wall -Wextra -Wcast-align -Wshadow -Wwrite-strings -Wctor-dtor-privacy -Wnon-virtual-dtor -Wreorder -Wsign-promo -Wundef -Wunreachable-code " # -Wcast-qual -Wbad-function-cast -Wwrite-strings -Woverloaded-virtual -Wmissing-declarations
+
+ XIPH_ADD_CFLAGS([-Wdeclaration-after-statement])
+- XIPH_ADD_CFLAGS([-D_FORTIFY_SOURCE=2])
+
+ AC_LANG_PUSH([C++])
+ XIPH_ADD_CXXFLAGS([-Weffc++])