summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-12 00:20:26 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-12 00:20:58 -0400
commite17e4d8bffe19eb873f7d823b19aeb4c1d1455f2 (patch)
tree4e17fcedd302d17ad7f8f747f95337eca58022ea /media-gfx
parentmedia-sound/csound: mark as LTO-unsafe (diff)
downloadgentoo-e17e4d8bffe19eb873f7d823b19aeb4c1d1455f2.tar.gz
gentoo-e17e4d8bffe19eb873f7d823b19aeb4c1d1455f2.tar.bz2
gentoo-e17e4d8bffe19eb873f7d823b19aeb4c1d1455f2.zip
media-gfx/xv: mark as LTO-unsafe
Closes: https://bugs.gentoo.org/859823 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/xv/xv-3.10a-r22.ebuild5
-rw-r--r--media-gfx/xv/xv-5.2.0.ebuild7
2 files changed, 11 insertions, 1 deletions
diff --git a/media-gfx/xv/xv-3.10a-r22.ebuild b/media-gfx/xv/xv-3.10a-r22.ebuild
index 6349d9814431..9141002ec745 100644
--- a/media-gfx/xv/xv-3.10a-r22.ebuild
+++ b/media-gfx/xv/xv-3.10a-r22.ebuild
@@ -70,6 +70,11 @@ src_prepare() {
}
src_compile() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/859823
+ # https://github.com/jasper-software/xv/issues/25
+ filter-lto
+
emake \
CC="$(tc-getCC)" CCOPTS="${CPPFLAGS} ${CFLAGS}" LDFLAGS="${LDFLAGS}" \
PREFIX="${EPREFIX}"/usr \
diff --git a/media-gfx/xv/xv-5.2.0.ebuild b/media-gfx/xv/xv-5.2.0.ebuild
index 49af68754450..a1e2d3e14fb9 100644
--- a/media-gfx/xv/xv-5.2.0.ebuild
+++ b/media-gfx/xv/xv-5.2.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake desktop
+inherit cmake desktop flag-o-matic
JUMBOV=20070520
DESCRIPTION="Interactive image manipulation program supporting a wide variety of formats"
@@ -33,6 +33,11 @@ PATCHES=(
)
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/859823
+ # https://github.com/jasper-software/xv/issues/25
+ filter-lto
+
local mycmakeargs=(
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
-DXV_ENABLE_JPEG=$(usex jpeg)