summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2024-09-07 17:37:50 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-10-07 09:58:37 +0300
commit84f88e5254f129611933a930e2f18551d8bbea7c (patch)
treeae1580535e18507749fc5f5a917262e9a77280fd /media-gfx
parentmedia-gfx/gnofract4d: drop 4.3_p20221125-r1, 4.3_p20230717 (diff)
downloadgentoo-84f88e5254f129611933a930e2f18551d8bbea7c.tar.gz
gentoo-84f88e5254f129611933a930e2f18551d8bbea7c.tar.bz2
gentoo-84f88e5254f129611933a930e2f18551d8bbea7c.zip
media-gfx/gnofract4d: add 4.3_p20240821
Signed-off-by: Chris Mayo <aklhfex@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38501 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gnofract4d/Manifest1
-rw-r--r--media-gfx/gnofract4d/gnofract4d-4.3_p20240821.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/media-gfx/gnofract4d/Manifest b/media-gfx/gnofract4d/Manifest
index 4662dd4b377e..43afc202453d 100644
--- a/media-gfx/gnofract4d/Manifest
+++ b/media-gfx/gnofract4d/Manifest
@@ -1 +1,2 @@
DIST gnofract4d-4.3_p20240324.tar.gz 18274057 BLAKE2B 183bf96e0429fa676f1c6fca4ae6466c489d0fe5ffee09ae161e01d0f22b4e77165f846416702c026f5d73a27833dfebd49f5c3131c621c9b1abd2ee9fc5529d SHA512 a174683b659347e4a7203d78d309ab41971d105131d40ea60490871477e80109624405f7012e455389ccc9325e08f224a1d3ea2d4e0c23fc9c5ca4fb83f9dfaa
+DIST gnofract4d-4.3_p20240821.tar.gz 18274253 BLAKE2B edfbd9a21b81f0fb051bbe6aef5ff97c77271985b7ecd0d3900ec70b208b1f2e5b75935d6213a761f555b2d4fe973e71b7859a56f2c2547f09321c6e75cc6981 SHA512 50abc3b5e9168308cbcff963a5aee00cd1f9a5a7a679d23023e6b21e82a1e04fc5fe8b55a10df39b1f71a85450824a75b2661abce9988746b9643acb78fa02e5
diff --git a/media-gfx/gnofract4d/gnofract4d-4.3_p20240821.ebuild b/media-gfx/gnofract4d/gnofract4d-4.3_p20240821.ebuild
new file mode 100644
index 000000000000..03e0f31ababe
--- /dev/null
+++ b/media-gfx/gnofract4d/gnofract4d-4.3_p20240821.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit meson optfeature python-single-r1 virtualx xdg
+
+COMMIT="4202edc865d1f5f3ce3bd3c5fdd72b767f0b89e4"
+
+DESCRIPTION="A program for drawing beautiful mathematically-based images known as fractals"
+HOMEPAGE="https://fract4d.github.io/gnofract4d/"
+SRC_URI="https://github.com/fract4d/gnofract4d/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ media-libs/libjpeg-turbo:0=
+ media-libs/libpng:0="
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ gui-libs/gtk:4[introspection]"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ media-video/ffmpeg[vpx,zlib]
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
+ )"
+
+src_prepare() {
+ sed -i "s:4.3:${PV}:" meson.build || die
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
+ -Dstrip=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+ python_fix_shebang "${ED}"/usr/bin/gnofract4d
+}
+
+src_test() {
+ local EPYTEST_IGNORE=(
+ # test_regress.py does not provide pytest with any tests and inspecting it requires dev-python/pillow
+ test_regress.py
+ )
+ local EPYTEST_DESELECT=(
+ # terminate called after throwing an instance of 'std::exception'
+ test_fract4d.py::Test::testFDSite
+ )
+ use x86 && EPYTEST_DESELECT+=(
+ # https://bugs.gentoo.org/890796
+ test_fractal.py::Test::testDiagonal
+ test_fractal.py::Test::testRecolor
+ )
+ TMPDIR="${T}" virtx epytest
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "creating videos" media-video/ffmpeg[vpx,zlib]
+}