summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2024-08-30 10:36:37 -0500
committerBen Kohler <bkohler@gentoo.org>2024-08-30 10:37:39 -0500
commit6d1028cd64956d7b7990e4ca43156d5916aae33a (patch)
tree0dd6807711523db334f8ed9c7a697edadc761a2b /media-gfx
parentdev-build/bmake: drop 20240711 (diff)
downloadgentoo-6d1028cd64956d7b7990e4ca43156d5916aae33a.tar.gz
gentoo-6d1028cd64956d7b7990e4ca43156d5916aae33a.tar.bz2
gentoo-6d1028cd64956d7b7990e4ca43156d5916aae33a.zip
media-gfx/rawtherapee: add 5.11
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/rawtherapee/Manifest1
-rw-r--r--media-gfx/rawtherapee/metadata.xml4
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.11.ebuild80
3 files changed, 85 insertions, 0 deletions
diff --git a/media-gfx/rawtherapee/Manifest b/media-gfx/rawtherapee/Manifest
index 23e17c128f5e..1b8ab516b025 100644
--- a/media-gfx/rawtherapee/Manifest
+++ b/media-gfx/rawtherapee/Manifest
@@ -1 +1,2 @@
DIST rawtherapee-5.10.tar.xz 16943724 BLAKE2B 2d1250a03f2902ffcff666514f9785036c808e9883957f674bfdb9545b2feac8f2313ab819e0cb64f39196bd3db36e8084b52bda6194de9197215824e695809c SHA512 79d6d54f90fec6006d3dff53aca00ccd385c398ebede2f06a223905d69e1045c6ab772bd5aca4bde01d9086c3c03183be22c0df521166b1af63b60bd7d0e1cfc
+DIST rawtherapee-5.11.tar.xz 18005652 BLAKE2B d4b4cb45042faf7eadb1c5bfbd7d1db2a452397d10eb12349d1d0a2ae4b9254beb3ee943cf3ddf40380f31abc653ec2c85fb0d4c8e2b1121402bbd41e74afaf0 SHA512 a37af6d99569a6b427379b76b980be8dca5007bf4ec8fc65663e9e8d13850dd2f547e1633f69ee495df105ca6f0f9ab4daf12beec29c9fff63e2e7e5083813b2
diff --git a/media-gfx/rawtherapee/metadata.xml b/media-gfx/rawtherapee/metadata.xml
index aa20bff17b1d..aa96f3399ed7 100644
--- a/media-gfx/rawtherapee/metadata.xml
+++ b/media-gfx/rawtherapee/metadata.xml
@@ -5,4 +5,8 @@
<email>bkohler@gentoo.org</email>
<name>Ben Kohler</name>
</maintainer>
+ <upstream>
+ <bugs-to>https://github.com/Beep6581/RawTherapee/issues</bugs-to>
+ <remote-id type="github">Beep6581/RawTherapee</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/media-gfx/rawtherapee/rawtherapee-5.11.ebuild b/media-gfx/rawtherapee/rawtherapee-5.11.ebuild
new file mode 100644
index 000000000000..c96b34c9b25b
--- /dev/null
+++ b/media-gfx/rawtherapee/rawtherapee-5.11.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P=${P/_rc/-rc}
+inherit cmake flag-o-matic toolchain-funcs xdg-utils
+
+DESCRIPTION="A powerful cross-platform raw image processing program"
+HOMEPAGE="https://www.rawtherapee.com/"
+SRC_URI="https://github.com/Beep6581/RawTherapee/releases/download/${PV}/${P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="openmp tcmalloc"
+
+RDEPEND="
+ dev-cpp/atkmm:0
+ dev-cpp/cairomm:0
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-cpp/pangomm:1.4
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+ gnome-base/librsvg:2
+ media-gfx/exiv2:=
+ media-libs/lcms:2
+ media-libs/lensfun
+ media-libs/libcanberra[gtk3]
+ media-libs/libiptcdata
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:0=
+ media-libs/tiff:=
+ sci-libs/fftw:3.0=
+ sys-libs/zlib
+ x11-libs/gtk+:3
+ tcmalloc? ( dev-util/google-perftools )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ # upstream tested that "fast-math" give wrong results, so filter it
+ # https://bugs.gentoo.org/show_bug.cgi?id=606896#c2
+ filter-flags -ffast-math
+ # -Ofast enable "fast-math" both in gcc and clang
+ replace-flags -Ofast -O3
+ # In case we add an ebuild for klt we can (i)use that one,
+ # see http://cecas.clemson.edu/~stb/klt/
+ local mycmakeargs=(
+ -DOPTION_OMP=$(usex openmp)
+ -DDOCDIR=/usr/share/doc/${PF}
+ -DCREDITSDIR=/usr/share/${PN}
+ -DLICENCEDIR=/usr/share/${PN}
+ -DCACHE_NAME_SUFFIX=""
+ -DWITH_SYSTEM_KLT="off"
+ -DENABLE_TCMALLOC=$(usex tcmalloc)
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}