summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-03-09 08:40:21 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2024-03-09 09:33:44 +0100
commit6b076cfd2aaab52e70d9f1e68c07f03b962e025d (patch)
tree9b2c5634437d17b6f31e2de43ac803dcbb25358b /media-gfx
parentprofiles: targets/desktop: Add dev-qt/qtbase[libproxy] to package.use (diff)
downloadgentoo-6b076cfd2aaab52e70d9f1e68c07f03b962e025d.tar.gz
gentoo-6b076cfd2aaab52e70d9f1e68c07f03b962e025d.tar.bz2
gentoo-6b076cfd2aaab52e70d9f1e68c07f03b962e025d.zip
media-gfx/geeqie: add 2.3
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/geeqie/Manifest2
-rw-r--r--media-gfx/geeqie/geeqie-2.3.ebuild115
2 files changed, 117 insertions, 0 deletions
diff --git a/media-gfx/geeqie/Manifest b/media-gfx/geeqie/Manifest
index 7a17851089e8..3aa1c6752ab0 100644
--- a/media-gfx/geeqie/Manifest
+++ b/media-gfx/geeqie/Manifest
@@ -2,3 +2,5 @@ DIST geeqie-2.1-docs.tar.xz 333756 BLAKE2B 2e569f4000befdaecebd6df9c94c59b8d9e05
DIST geeqie-2.1.tar.xz 1800612 BLAKE2B 60190532eb8830e12acf06e39046dd04ccf28ac5d3679f2063e6f6e102add0d398dfc70a57a758d0c16483d5314ec88cb56b54829103ad938b29ac1500f86fdc SHA512 1812234d349536626433bbb7670cd45ef5ce328bf58f603af8eb4a01f7d3db2557d5a812714b12a9b49559aa1fe1c186ceddf2f632c2b303d64d36ad746a2d2f
DIST geeqie-2.2-docs.tar.xz 356976 BLAKE2B 3bca2815a6f177a2f38b9a66ff6fa95dba510aa2afb36d5d6c9f6841c0c1b25c4f9aad7d45ef57d911f0caa2a8499a06aba2ccaf7e279382bf4304c88f11ea13 SHA512 0f89995573b02e82c715dcdf4d71a309691885ad785f1297d2fee01aff00f2aed43c9cff6900bddfa1a727598934ba7bb0ced32b0c86c6f1a115271a8a81592a
DIST geeqie-2.2.tar.xz 2169096 BLAKE2B fe7f21f5842ac7824ec37f0775d31e8dcd05934809f7bdd84d7dcb749d25976055050f42a8cea3cd414fb3c7e60055c9fa32b93cfef2af62de68f4d44af425c8 SHA512 7d03493b463a1949cbc5e377927abc4bc6fa62914e8cdddb30a832cb9c6caad579f5ba5bd2b8b0913b77063300c9c5ac1f7e671ddfb2ce18d8a8d0efcfb51dbe
+DIST geeqie-2.3-docs.tar.xz 362412 BLAKE2B e05adbd6b277cfccae20c2ed7840e447016b32a9bf5c5ad6feb143993b4856fbb623feb6684a21c235ad846923463bed45cf887b1854189f01a46c3961f26a18 SHA512 cab4739adecd1dcb9cde3a58a2e2c2262f4014bc7594ae22af69b8bdbb14f6849b1e2267646301f31ebde76b2b2abc05e75aac3325e35cb88f9dc40703f2d943
+DIST geeqie-2.3.tar.xz 2184604 BLAKE2B dbd2d52d146d373a9694a7371a8ac44571e63895cf6cea7acb549a1135b4cf5869737cdf780ca6afdb14eda1338cb275791eaac1cd7596ed58eb07759cf75778 SHA512 9f45974d12c1f193a4a3624064b967fc06cf9c906c45160a4945a8f6a9d814b929b92c45a35006c7f1b20fa5fe360858f24fd54adbcd8863c3e7d787a3429899
diff --git a/media-gfx/geeqie/geeqie-2.3.ebuild b/media-gfx/geeqie/geeqie-2.3.ebuild
new file mode 100644
index 000000000000..db97d02cdbaa
--- /dev/null
+++ b/media-gfx/geeqie/geeqie-2.3.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+LUA_COMPAT=( lua5-{3,4} )
+
+inherit flag-o-matic lua-single meson optfeature xdg
+
+DESCRIPTION="A lightweight GTK image viewer forked from GQview"
+HOMEPAGE="http://www.geeqie.org"
+SRC_URI="https://github.com/BestImageViewer/${PN}/releases/download/v${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~voyageur/distfiles/${P}-docs.tar.xz"
+# Doc build:
+# clone git at matching tag
+# mkdir build; ./gen_changelog.sh . build;
+# pandoc README.md -o build/README.html
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+IUSE="debug djvu exif ffmpegthumbnailer heif jpeg jpeg2k jpegxl lcms lua map pdf raw spell tiff webp xmp zip"
+
+RDEPEND="gnome-extra/zenity
+ virtual/libintl
+ x11-libs/gtk+:3
+ djvu? ( app-text/djvu )
+ exif? ( >=media-gfx/exiv2-0.17:=[xmp?] )
+ ffmpegthumbnailer? ( media-video/ffmpegthumbnailer )
+ heif? ( >=media-libs/libheif-1.3.2 )
+ jpeg2k? ( >=media-libs/openjpeg-2.3.0:2= )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ jpegxl? ( >=media-libs/libjxl-0.3.7:= )
+ lcms? ( media-libs/lcms:2 )
+ lua? ( ${LUA_DEPS} )
+ map? ( media-libs/clutter-gtk
+ media-libs/libchamplain:0.12[gtk] )
+ pdf? ( >=app-text/poppler-0.62[cairo] )
+ raw? ( >=media-libs/libraw-0.20:= )
+ spell? ( app-text/gspell )
+ tiff? ( media-libs/tiff:= )
+ webp? ( gui-libs/gdk-pixbuf-loader-webp:= )
+ zip? ( >=app-arch/libarchive-3.4.0 )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ || ( dev-util/xxdi app-editors/vim-core )
+ dev-util/glib-utils
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+
+pkg_setup() {
+ # Do not require setting LUA_SINGLE_TARGET if lua is not used
+ use lua && lua-single_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Disable doc build - not useful most of the time per upstream
+ sed -e "/subdir('doc')/d" -i meson.build || die
+}
+
+src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/585432
+ # https://github.com/BestImageViewer/geeqie/issues/1270
+ filter-lto
+
+ local emesonargs=(
+ -Dgq_helpdir="share/doc/${PF}"
+ -Dgq_htmldir="share/doc/${PF}/html"
+ $(meson_use debug)
+ $(meson_feature djvu)
+ $(meson_feature exif exiv2)
+ $(meson_feature ffmpegthumbnailer videothumbnailer)
+ $(meson_feature heif)
+ $(meson_feature jpeg)
+ $(meson_feature jpeg2k j2k)
+ $(meson_feature jpegxl)
+ $(meson_feature lcms cms)
+ $(meson_feature lua)
+ $(meson_feature map gps-map)
+ $(meson_feature pdf)
+ $(meson_feature raw libraw)
+ $(meson_feature spell)
+ $(meson_feature tiff)
+ $(meson_feature zip archive)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Manually generated ChangeLog
+ dodoc "${WORKDIR}"/${P}-docs/*
+
+ # The application needs access to some uncompressed doc files.
+ docompress -x /usr/share/doc/${PF}/AUTHORS
+ docompress -x /usr/share/doc/${PF}/ChangeLog
+ docompress -x /usr/share/doc/${PF}/README.md
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "Camera import and tethered photography plugins" media-gfx/gphoto2
+ optfeature "Lens ID plugin" media-libs/exiftool
+ optfeature "Image crop plugin" "media-libs/exiftool media-gfx/imagemagick"
+ optfeature "Image rotate plugin (JPEG)" media-gfx/fbida
+ optfeature "Image rotate plugin (TIFF/PNG)" media-gfx/imagemagick
+ optfeature "Print preview functionality" app-text/evince
+}