summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-04 01:09:41 +0000
committerSam James <sam@gentoo.org>2021-12-04 01:09:46 +0000
commit1f271a2a1c109baac36ec566b00683f8e1589ae3 (patch)
treefefb8912fd99c33b9176f1ed3ba9b277ffe7cfed /media-gfx
parentmedia-gfx/openvdb: fix minor typo in patch comment (diff)
downloadgentoo-1f271a2a1c109baac36ec566b00683f8e1589ae3.tar.gz
gentoo-1f271a2a1c109baac36ec566b00683f8e1589ae3.tar.bz2
gentoo-1f271a2a1c109baac36ec566b00683f8e1589ae3.zip
media-gfx/openvdb: add 8.2.0
Trying without setting PYOPENVDB_INSTALL_DIRECTORY as that _seems_ to work and allows us to avoid backporting a non-trivial patch to 8.x. This should fix some Python-related build issues in previous versions of 8.x (which should be fixed already in 9.x). Bug: https://bugs.gentoo.org/790350 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/openvdb/Manifest1
-rw-r--r--media-gfx/openvdb/openvdb-8.2.0.ebuild130
2 files changed, 131 insertions, 0 deletions
diff --git a/media-gfx/openvdb/Manifest b/media-gfx/openvdb/Manifest
index dcd5a8c1c378..e9238716b63b 100644
--- a/media-gfx/openvdb/Manifest
+++ b/media-gfx/openvdb/Manifest
@@ -2,4 +2,5 @@ DIST openvdb-7.0.0.tar.gz 1872744 BLAKE2B e3a8c8d51f77e115d3d397abde0860a6322d56
DIST openvdb-7.1.0.tar.gz 1956052 BLAKE2B 7778d67bcc65ecb17b86f6e67a9e5f2d6574de5869a0a9c675ad7bc8540154c0f249a91c68a9da9068a3951b3e919e5676450fcaf13921c6263e7c87012a2f29 SHA512 49806375f7e6d7b12eaba24e672a068531d2f8a05f12eba29069710d2682f9983f9e6ad26047eed4b28e337f8d0e738b90130582863c710e8dd1e720bf0addad
DIST openvdb-8.0.1.tar.gz 2299276 BLAKE2B e65bd4710ff65e20570013399d1e71a32e8f80c5e3b5527fc17d23c7f86ead7e04483cf7ba5266f26343604677d3a0dcafc01474baf7ef09b98f1f41a66119a2 SHA512 6a5a8b637429295efa72494aef82ff92dd83092591b713f56930ccf4aab3a33806d1263bfd090c27239eab97b4fdc053288dc545e631f8a7d4ca180a32331be2
DIST openvdb-8.1.0.tar.gz 2619432 BLAKE2B ba06e8dc24876da0ed1a2b5560e8793ad1e42b45b2018734c98c9b8f1d43bdb4aa098243a68de90efb18cb0454a9ea2a59c87f411d2c6492c5bce95dc047a6f0 SHA512 081ccedb122ff9bd73e0cd7ff083ad0ff0165e0cf6305187edcbe90ff12f01ec085c91ad5c52c53596035e0c2afd5b8801e6c00374b0fc4b0cc111f5c7f37eb5
+DIST openvdb-8.2.0.tar.gz 2656278 BLAKE2B b381459fb770800bb03bc8a6b3122c6684ab508f11be024e0eb3951bfbcef14e626e2d4468e91ea17fd6792f23810eafe8b05e19d46eb0e6200c73ccf296116a SHA512 aed6b5884a9cfd42f72357ad090c5dcf7829b0e5672ab61e31206e889c085ce5a7bcb89476ceac552a837d394011951528e2b3cffc77baadc491a2e7a31d5e86
DIST openvdb-9.0.0.tar.gz 2945040 BLAKE2B c47a8088ba30d3cbecff04dbfd2d48b39a254e54149d8692c3a7157a99a1c555ef9747b77aeab6f8709b61c348d496765f2cfcbb0975e21f533072871f3fa422 SHA512 1410b7b04b03fb09d6775ebe7b95e7c0a484d5f29c84203530ed30ccb7c061470be1abb93189010617342e57f3fecdd66a115c6d222024e68e2384a7fb196194
diff --git a/media-gfx/openvdb/openvdb-8.2.0.ebuild b/media-gfx/openvdb/openvdb-8.2.0.ebuild
new file mode 100644
index 000000000000..9b71b3a635df
--- /dev/null
+++ b/media-gfx/openvdb/openvdb-8.2.0.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Library for the efficient manipulation of volumetric data"
+HOMEPAGE="https://www.openvdb.org"
+SRC_URI="https://github.com/AcademySoftwareFoundation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0/8"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="cpu_flags_x86_avx cpu_flags_x86_sse4_2 +blosc doc numpy python static-libs test utils zlib abi6-compat abi7-compat +abi8-compat"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ numpy? ( python )
+ ^^ ( abi6-compat abi7-compat abi8-compat )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+# 8.2.0 should support OpenEXR 3 / imath but it's going to cause issues with Blender AFAIK
+# so let's avoid it for now.
+RDEPEND="
+ dev-cpp/tbb:=
+ dev-libs/boost:=
+ dev-libs/jemalloc:=
+ dev-libs/log4cplus:=
+ media-libs/glfw
+ media-libs/glu
+ media-libs/ilmbase:=
+ media-libs/openexr:0=
+ sys-libs/zlib:=
+ x11-libs/libXcursor
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ blosc? ( dev-libs/c-blosc:= )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/boost:=[numpy?,python?,${PYTHON_USEDEP}]
+ numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ ')
+ )
+ zlib? ( sys-libs/zlib )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ >=dev-util/cmake-3.16.2-r1
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+ test? ( dev-util/cppunit dev-cpp/gtest )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-7.1.0-0001-Fix-multilib-header-source.patch"
+ "${FILESDIR}/${PN}-8.0.1-add-consistency-for-NumPy-find_package-call.patch"
+ "${FILESDIR}/${PN}-8.1.0-glfw-libdir.patch"
+ #"${FILESDIR}/${PN}-9.0.0-unconditionally-search-Python-interpreter.patch"
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myprefix="${EPREFIX}/usr/"
+
+ local version
+ if use abi6-compat; then
+ version=6
+ elif use abi7-compat; then
+ version=7
+ elif use abi8-compat; then
+ version=8
+ else
+ die "OpenVDB ABI version is not compatible"
+ fi
+
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}/"
+ -DOPENVDB_ABI_VERSION_NUMBER="${version}"
+ -DOPENVDB_BUILD_DOCS=$(usex doc)
+ -DOPENVDB_BUILD_UNITTESTS=$(usex test)
+ -DOPENVDB_BUILD_VDB_LOD=$(usex utils)
+ -DOPENVDB_BUILD_VDB_RENDER=$(usex utils)
+ -DOPENVDB_BUILD_VDB_VIEW=$(usex utils)
+ -DOPENVDB_CORE_SHARED=ON
+ -DOPENVDB_CORE_STATIC=$(usex static-libs)
+ -DOPENVDB_ENABLE_RPATH=OFF
+ -DUSE_BLOSC=$(usex blosc)
+ -DUSE_ZLIB=$(usex zlib)
+ -DUSE_CCACHE=OFF
+ -DUSE_COLORED_OUTPUT=ON
+ # Off for now until 9.0.0 for OpenEXR 3 support
+ -DUSE_IMATH_HALF=OFF
+ -DUSE_LOG4CPLUS=ON
+ )
+
+ if use python; then
+ mycmakeargs+=(
+ -DOPENVDB_BUILD_PYTHON_MODULE=ON
+ -DUSE_NUMPY=$(usex numpy)
+ -DOPENVDB_BUILD_PYTHON_UNITTESTS=$(usex test)
+ -DPython_EXECUTABLE="${PYTHON}"
+ -DPython_INCLUDE_DIR="$(python_get_includedir)"
+ )
+ fi
+
+ if use cpu_flags_x86_avx; then
+ mycmakeargs+=( -DOPENVDB_SIMD=AVX )
+ elif use cpu_flags_x86_sse4_2; then
+ mycmakeargs+=( -DOPENVDB_SIMD=SSE42 )
+ fi
+
+ cmake_src_configure
+}