summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/cptutils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/cptutils')
-rw-r--r--media-gfx/cptutils/Manifest2
-rw-r--r--media-gfx/cptutils/cptutils-1.54.ebuild27
-rw-r--r--media-gfx/cptutils/cptutils-1.59.ebuild27
-rw-r--r--media-gfx/cptutils/files/cptutils-1.54-parallel-make.patch30
-rw-r--r--media-gfx/cptutils/metadata.xml5
5 files changed, 91 insertions, 0 deletions
diff --git a/media-gfx/cptutils/Manifest b/media-gfx/cptutils/Manifest
new file mode 100644
index 000000000000..1e95ced59b1b
--- /dev/null
+++ b/media-gfx/cptutils/Manifest
@@ -0,0 +1,2 @@
+DIST cptutils-1.54.tar.gz 587268 SHA256 07848a1e76337595c1ee7619638f16b6c0818717b2460096093078866402cc22 SHA512 8bae9d5d9d5b2ae0e39eda6e157734fa17afe6225b4966c93db4072f31e7ec91c7c0a7b4b1cf0bfdd696444485a61e93da725c2d94854b4de5e1c9936bec3e37 WHIRLPOOL fb39ef953fd92a177f25a262b9122decad22713019a1821d8a8a048b12ddbbd125e860fec923148e1529b54883a6feb9b155b5b28c18be00ef763b0b6ae0137c
+DIST cptutils-1.59.tar.gz 599033 SHA256 d4f3adf55bc1643d64d513371c0948d37ad4f0bb614ea90557c23d7ebd860616 SHA512 b8e78eadb7353d6cbb8b01eb3eb2791e425697ccff6df50125392cb476e7b1bdb5c83b40e27d9c28899f4ed364e46e195febaa28374ffe5abca697665838f7fe WHIRLPOOL ad7c95a5be927199e83f24ff94950c2595738139c8fe84c489561d0d26c61509c493966b806213cd91d87c3efd87b5ec15fc1ec9dc2bb8fd74278f78cba0e35f
diff --git a/media-gfx/cptutils/cptutils-1.54.ebuild b/media-gfx/cptutils/cptutils-1.54.ebuild
new file mode 100644
index 000000000000..4c5e7200184a
--- /dev/null
+++ b/media-gfx/cptutils/cptutils-1.54.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 eutils
+
+DESCRIPTION="A number of utilities for the manipulation of color gradient files"
+HOMEPAGE="http://soliton.vm.bytemark.co.uk/pub/jjg/en/code/cptutils.html"
+SRC_URI="http://soliton.vm.bytemark.co.uk/pub/jjg/code/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-libs/libxml2:2
+ media-libs/libpng:0="
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}"
+DEPEND="${CDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-parallel-make.patch
+ python_fix_shebang src/gradient-convert/gradient-convert.py
+}
diff --git a/media-gfx/cptutils/cptutils-1.59.ebuild b/media-gfx/cptutils/cptutils-1.59.ebuild
new file mode 100644
index 000000000000..4fd45152bd16
--- /dev/null
+++ b/media-gfx/cptutils/cptutils-1.59.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 eutils
+
+DESCRIPTION="A number of utilities for the manipulation of color gradient files"
+HOMEPAGE="http://soliton.vm.bytemark.co.uk/pub/jjg/en/code/cptutils/"
+SRC_URI="http://soliton.vm.bytemark.co.uk/pub/jjg/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-libs/libxml2:2
+ media-libs/libpng:0="
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}"
+DEPEND="${CDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.54-parallel-make.patch
+ python_fix_shebang src/gradient-convert/gradient-convert.py
+}
diff --git a/media-gfx/cptutils/files/cptutils-1.54-parallel-make.patch b/media-gfx/cptutils/files/cptutils-1.54-parallel-make.patch
new file mode 100644
index 000000000000..c3497763b2ed
--- /dev/null
+++ b/media-gfx/cptutils/files/cptutils-1.54-parallel-make.patch
@@ -0,0 +1,30 @@
+--- cptutils-1.54/Makefile.in
++++ cptutils-1.54/Makefile.in
+@@ -8,23 +8,22 @@
+ RUBBISH = *~
+ CONFFILES = config.cache config.log config.status configure Makefile
+ DIST = cptutils-$(VERSION)
+-MAKE_SRC = $(MAKE) -C src
+
+ # targets
+
+ default : all
+
+ all :
+- $(MAKE_SRC) all
++ $(MAKE) -C src all
+
+ install :
+- $(MAKE_SRC) install
++ $(MAKE) -C src install
+
+ test check :
+- $(MAKE_SRC) --quiet test
++ $(MAKE) -C src --quiet test
+
+ unit :
+- $(MAKE_SRC) --quiet unit
++ $(MAKE) -C src --quiet unit
+
+ clean :
+ $(RM) $(RUBBISH)
diff --git a/media-gfx/cptutils/metadata.xml b/media-gfx/cptutils/metadata.xml
new file mode 100644
index 000000000000..e770d1bc9a96
--- /dev/null
+++ b/media-gfx/cptutils/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>graphics</herd>
+</pkgmetadata>