summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/dejavu/dejavu-2.35.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/dejavu/dejavu-2.35.ebuild')
-rw-r--r--media-fonts/dejavu/dejavu-2.35.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/media-fonts/dejavu/dejavu-2.35.ebuild b/media-fonts/dejavu/dejavu-2.35.ebuild
new file mode 100644
index 000000000000..2cb1ac871089
--- /dev/null
+++ b/media-fonts/dejavu/dejavu-2.35.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit font versionator
+
+DESCRIPTION="DejaVu fonts, bitstream vera with ISO-8859-2 characters"
+HOMEPAGE="http://dejavu.sourceforge.net/"
+
+# If you want to test snapshot from dejavu.sf.net/snapshots/
+# just rename ebuild to dejavu-2.22.20071220.2156.ebuild
+MY_PV=$(get_version_component_range 1-2)
+snapv=$(get_version_component_range 3-4)
+snapv=${snapv/./-}
+MY_BP=${PN}-fonts-ttf-${MY_PV}
+MY_SP=${PN}-fonts-${MY_PV}
+
+if [[ -z ${snapv} ]]; then
+ SRC_URI="!fontforge? ( mirror://sourceforge/${PN}/${MY_BP}.tar.bz2 )
+ fontforge? ( mirror://sourceforge/${PN}/${MY_SP}.tar.bz2 )"
+else
+ SRC_URI="!fontforge? ( http://dejavu.sourceforge.net/snapshots/${MY_BP}-${snapv}.tar.bz2 )
+ fontforge? ( http://dejavu.sourceforge.net/snapshots/${MY_SP}-${snapv}.tar.bz2 )"
+fi
+
+LICENSE="BitstreamVera"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="fontforge"
+
+DEPEND="fontforge? ( x11-apps/mkfontscale
+ >=media-gfx/fontforge-20080429
+ x11-apps/mkfontdir
+ dev-perl/Font-TTF
+ app-i18n/unicode-data
+ >media-libs/fontconfig-2.6.0 )"
+
+if use fontforge; then
+ S=${WORKDIR}/${MY_SP}
+ FONT_S=${S}/build
+else
+ S=${WORKDIR}/${MY_BP}
+ FONT_S=${S}/ttf
+fi
+
+FONT_CONF=(
+ "${S}"/fontconfig/20-unhint-small-dejavu-sans-mono.conf
+ "${S}"/fontconfig/20-unhint-small-dejavu-sans.conf
+ "${S}"/fontconfig/20-unhint-small-dejavu-serif.conf
+ "${S}"/fontconfig/57-dejavu-sans-mono.conf
+ "${S}"/fontconfig/57-dejavu-sans.conf
+ "${S}"/fontconfig/57-dejavu-serif.conf )
+
+FONT_SUFFIX="ttf"
+DOCS="AUTHORS NEWS README status.txt langcover.txt unicover.txt"
+
+src_compile() {
+ if use fontforge; then
+ emake -j1 \
+ BLOCKS=/usr/share/unicode-data/Blocks.txt \
+ UNICODEDATA=/usr/share/unicode-data/UnicodeData.txt \
+ FC-LANG=/usr/share/fc-lang \
+ full sans \
+ || die "emake failed"
+ fi
+}
+
+src_install() {
+ font_src_install
+ if use fontforge; then
+ dodoc build/*.txt
+ fi
+}