summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrobert <gentoo.bugzilla.2012@r123.de>2017-11-19 15:02:37 +0100
committerAmy Liffey <amynka@gentoo.org>2017-11-24 09:33:53 +0100
commit1ff347c9b83bdc135746d9f374c4657fdf2560d2 (patch)
treeadc29c20157c201c975a4d10b78ae3bfeefb501c /mail-client/alpine
parentdev-lang/ghc: bump up to 8.2.2, no keywords, binaries or core library pins (diff)
downloadgentoo-1ff347c9b83bdc135746d9f374c4657fdf2560d2.tar.gz
gentoo-1ff347c9b83bdc135746d9f374c4657fdf2560d2.tar.bz2
gentoo-1ff347c9b83bdc135746d9f374c4657fdf2560d2.zip
mail-client/alpine: bump to version 2.21
Closes: https://bugs.gentoo.org/445276
Diffstat (limited to 'mail-client/alpine')
-rw-r--r--mail-client/alpine/Manifest1
-rw-r--r--mail-client/alpine/alpine-2.21.ebuild86
-rw-r--r--mail-client/alpine/metadata.xml8
3 files changed, 95 insertions, 0 deletions
diff --git a/mail-client/alpine/Manifest b/mail-client/alpine/Manifest
index 5e03d759ec2c..6d2604cb2e73 100644
--- a/mail-client/alpine/Manifest
+++ b/mail-client/alpine/Manifest
@@ -1,2 +1,3 @@
DIST alpine-2.00-chappa-115-all.patch.gz 212705 SHA256 1503ae09b6a4a74828e3472c4987b48a310f817e7fd93ca385724660aa234d7f SHA512 5e9fcb6a80dbd18bed26109caa6b7aa5eeb88de420861d9998c32f031e8279d6367c28b6670fb54203d1b14c3dc47cf5ad25b42e4949157de64f3f1fd36d0aa7 WHIRLPOOL d9fef2fb0a07acfb8ba4e5bedbc0140a09020967e52b16853907db47b1a7e35286022c2a03b1670fe377015393d22b27bfa9f12780de05bac1f3458a81f75527
DIST alpine-2.00.tar.bz2 5222673 SHA256 c85db8405af90375ba2440c85b7952d80996154e9916b83acca558dc82e0a2a6 SHA512 17c6e65fbe767d4f9ffb3d3c2bb3deeab9d3620cd046cbb0009290aa484c9254effa992957631f0603bd82b82aeca2923d391aee6d20a7684d5830fbca8ce4d2 WHIRLPOOL 6c1fed63e826c12c6e39e8f79e2b33f3b85545e54c32fdbe918636086c0aaaa26073883946061a6b52df50af711b7d6bb6647a177f051afccccdbd0cf473bbc3
+DIST alpine-2.21.tar.xz 4720856 SHA256 6030b6881b8168546756ab3a5e43628d8d564539b0476578e287775573a77438 SHA512 a2a36a033c8af79810816a7da7185c269808ba6d84d013691fd8b3764c63f5fb2284e6844ec5a5e99d168514ae636debf59fae962533a2916679e4e9109c6264 WHIRLPOOL 54113ac1516e9f185ff4ed2841624145ec72514a8ce1d45c2907a8e5ad6b6e79ea6780d22d15a19053a69ae97cc2ef630ff8579ffe746a8b715d81a7db59a6d1
diff --git a/mail-client/alpine/alpine-2.21.ebuild b/mail-client/alpine/alpine-2.21.ebuild
new file mode 100644
index 000000000000..889913b3b1f8
--- /dev/null
+++ b/mail-client/alpine/alpine-2.21.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools toolchain-funcs
+
+DESCRIPTION="alpine is an easy to use text-based based mail and news client"
+HOMEPAGE="http://www.washington.edu/alpine/ http://alpine.freeiz.com/alpine/ http://repo.or.cz/alpine.git/"
+SRC_URI="http://alpine.freeiz.com/alpine/release/src/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~alpha ~ia64 ~ppc ~sparc"
+IUSE="doc ipv6 kerberos ldap libressl nls onlyalpine passfile smime spell ssl threads"
+
+DEPEND="virtual/pam
+ >=sys-libs/ncurses-5.1:0=
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ ldap? ( net-nds/openldap )
+ kerberos? ( app-crypt/mit-krb5 )
+ spell? ( app-text/aspell )
+"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ !onlyalpine? ( !mail-client/pine )
+ !<=net-mail/uw-imap-2004g
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ myconf=(
+ --without-tcl
+ --with-system-pinerc="${EPREFIX}"/etc/pine.conf
+ --with-system-fixed-pinerc="${EPREFIX}"/etc/pine.conf.fixed
+ )
+
+ if use ssl; then
+ myconf+=(
+ --with-ssl-include-dir="${EPREFIX}"/usr/include/openssl
+ --with-ssl-lib-dir="${EPREFIX}"/usr/$(get_libdir)
+ --with-ssl-certs-dir="${EPREFIX}"/etc/ssl/certs
+ )
+ fi
+ econf \
+ $(use_with ldap) \
+ $(use_with ssl) \
+ $(use_with passfile passfile .pinepwd) \
+ $(use_with kerberos krb5) \
+ $(use_with threads pthread) \
+ $(use_with spell interactive-spellcheck /usr/bin/aspell) \
+ $(use_enable nls) \
+ $(use_with ipv6) \
+ $(use_with smime) \
+ "${myconf[@]}"
+}
+
+src_compile() {
+ emake -j1 AR=$(tc-getAR)
+}
+
+src_install() {
+ if use onlyalpine ; then
+ dobin alpine/alpine
+ doman doc/alpine.1
+ else
+ emake DESTDIR="${D}" install
+ doman doc/man1/*.1
+ fi
+
+ dodoc NOTICE README*
+
+ if use doc ; then
+ dodoc doc/brochure.txt
+
+ docinto html/tech-notes
+ dodoc -r doc/tech-notes/*.html
+ dodoc -r doc/tech-notes/*.txt
+ fi
+}
diff --git a/mail-client/alpine/metadata.xml b/mail-client/alpine/metadata.xml
index a2485d48e63f..282a8630f65e 100644
--- a/mail-client/alpine/metadata.xml
+++ b/mail-client/alpine/metadata.xml
@@ -1,10 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo.bugzilla.2012@r123.de</email>
+ <name>Robert Siebeck</name>
+ </maintainer>
<maintainer type="project">
<email>net-mail@gentoo.org</email>
<name>Net-Mail</name>
</maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<use>
<flag name="chappa">enhance alpine by applying Eduardo Chappa's
patches</flag>