summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-04-17 21:00:39 +0300
committerJimi Huotari <chiitoo@gentoo.org>2024-06-15 00:48:29 +0300
commite527a146b38801d27dab72a5a3f0b9207309ecf2 (patch)
tree2fa13a4917df0e1d46cb8b8fa5496142b5a306bf /lxqt-base/lxqt-config
parentlxqt-base/lxqt-admin: add version 2.0.0 (diff)
downloadgentoo-e527a146b38801d27dab72a5a3f0b9207309ecf2.tar.gz
gentoo-e527a146b38801d27dab72a5a3f0b9207309ecf2.tar.bz2
gentoo-e527a146b38801d27dab72a5a3f0b9207309ecf2.zip
lxqt-base/lxqt-config: add version 2.0.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'lxqt-base/lxqt-config')
-rw-r--r--lxqt-base/lxqt-config/Manifest1
-rw-r--r--lxqt-base/lxqt-config/lxqt-config-2.0.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-config/Manifest b/lxqt-base/lxqt-config/Manifest
index 09f5160c8913..e711a2bed153 100644
--- a/lxqt-base/lxqt-config/Manifest
+++ b/lxqt-base/lxqt-config/Manifest
@@ -1,2 +1,3 @@
DIST lxqt-config-1.3.0.tar.xz 370624 BLAKE2B 2015d2ec8f1a925e505b8c93b3db99fe351d8db742c78b2a19e8f8be7df47be619b3b5c313a693f1ac4e54b1f117aea5a706e8eae2d0fb6340fafe1b4a47412d SHA512 30610d1c90d897eb54ce5ee75a39721a7818b0164bc97dece5b74aec2032c3b0027316995d83c077352e93fd2f7ab319d1801ed5ce356b857805e855db71cd75
DIST lxqt-config-1.4.0.tar.xz 371628 BLAKE2B d7be05fdd55bfe2efe977184008ed6324e16e85c2bceb6b9c15e8ef11978d34ba0961b671978618ce4b7a836653477c4fa5cbc9b5dfead7a1c8a87e00c408bbd SHA512 a3e6722c3f63b3c7382ec84723e3a4d838d99b2c42ce731565f940873b275ef025b7bc1a570f165b7fce521eb77bb7b83b02e922bee251507b773c8de4f785fc
+DIST lxqt-config-2.0.0.tar.xz 380552 BLAKE2B 5b6dc5f1323609b487608efabcd3b3a2b2d14ee0374a9959b9ee1627146232ff8d91ea244b243a342217f06613424e5e0dca0b89bfef99771dcf8018fccba2ea SHA512 dbb96a069fa0b73c5e7cb6ed26d99ddf838df363b3dba5c6f8ac3dde4ab316646c6bea6fd6d463d9ddc76c38ce8b75dbf1fadc7e56d4c548a54c6d53b494bce3
diff --git a/lxqt-base/lxqt-config/lxqt-config-2.0.0.ebuild b/lxqt-base/lxqt-config/lxqt-config-2.0.0.ebuild
new file mode 100644
index 000000000000..b51636655a60
--- /dev/null
+++ b/lxqt-base/lxqt-config/lxqt-config-2.0.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake xdg-utils
+
+DESCRIPTION="LXQt system configuration control center"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2 GPL-2+ GPL-3 LGPL-2 LGPL-2+ LGPL-2.1+ WTFPL-2"
+SLOT="0"
+IUSE="+monitor +touchpad"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.0.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-4.0.0
+ >=dev-qt/qtbase-6.6:6[gui,widgets,xml]
+ >=dev-qt/qtsvg-6.6:6
+ =lxqt-base/liblxqt-${MY_PV}*:=
+ =lxqt-base/lxqt-menu-data-${MY_PV}*
+ sys-libs/zlib:=
+ x11-apps/setxkbmap
+ x11-libs/libxcb:=
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ monitor? ( kde-plasma/libkscreen:6= )
+ touchpad? (
+ virtual/libudev:=
+ x11-drivers/xf86-input-libinput
+ x11-libs/libXi
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MONITOR=$(usex monitor)
+ -DWITH_TOUCHPAD=$(usex touchpad)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ doman man/*.1 liblxqt-config-cursor/man/*.1 lxqt-config-appearance/man/*.1
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}