summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-16 11:05:09 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-16 11:05:09 +0100
commita32e1b3b02b5eb2cd25b1c25788f015b02fb224e (patch)
tree3e0deb5665b9911dbec07897c898c2d0ec26fbf8 /llvm-core
parentnet-misc/clockspeed: drop mirror and bindist restriction (diff)
downloadgentoo-a32e1b3b02b5eb2cd25b1c25788f015b02fb224e.tar.gz
gentoo-a32e1b3b02b5eb2cd25b1c25788f015b02fb224e.tar.bz2
gentoo-a32e1b3b02b5eb2cd25b1c25788f015b02fb224e.zip
llvm-core/clang-runtime: Resync 19.1.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'llvm-core')
-rw-r--r--llvm-core/clang-runtime/clang-runtime-19.1.7.ebuild25
1 files changed, 8 insertions, 17 deletions
diff --git a/llvm-core/clang-runtime/clang-runtime-19.1.7.ebuild b/llvm-core/clang-runtime/clang-runtime-19.1.7.ebuild
index d4206dc08c77..da17e274d8da 100644
--- a/llvm-core/clang-runtime/clang-runtime-19.1.7.ebuild
+++ b/llvm-core/clang-runtime/clang-runtime-19.1.7.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit multilib-build toolchain-funcs
+inherit multilib-build
DESCRIPTION="Meta-ebuild for clang runtime libraries"
HOMEPAGE="https://clang.llvm.org/"
@@ -11,7 +11,7 @@ HOMEPAGE="https://clang.llvm.org/"
LICENSE="metapackage"
SLOT="${PV%%.*}"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos"
-IUSE="+compiler-rt libcxx openmp +sanitize"
+IUSE="+compiler-rt libcxx offload openmp +sanitize"
REQUIRED_USE="sanitize? ( compiler-rt )"
RDEPEND="
@@ -22,19 +22,10 @@ RDEPEND="
)
)
libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
- openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
+ openmp? (
+ >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}]
+ offload? (
+ >=llvm-runtimes/offload-${PV}
+ )
+ )
"
-
-pkg_pretend() {
- if tc-is-clang; then
- ewarn "You seem to be using clang as a system compiler. As of clang-16,"
- ewarn "upstream has turned a few warnings that commonly occur during"
- ewarn "configure script runs into errors by default. This causes some"
- ewarn "configure tests to start failing, sometimes resulting in silent"
- ewarn "breakage, missing functionality or runtime misbehavior. It is"
- ewarn "not yet clear whether the change will remain or be reverted."
- ewarn
- ewarn "For more information, please see:"
- ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
- fi
-}