summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-20 13:53:34 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-20 14:10:32 +0100
commit82fc2666c98ed8d8dc886f93d484f5c8d2449767 (patch)
treebdc3120c06e1c0ffce9ef8c61f9a62b4c5beb878 /kde-plasma/kwayland-integration
parentkde-plasma/kwallet-pam: 5.26.90 version bump (diff)
downloadgentoo-82fc2666c98ed8d8dc886f93d484f5c8d2449767.tar.gz
gentoo-82fc2666c98ed8d8dc886f93d484f5c8d2449767.tar.bz2
gentoo-82fc2666c98ed8d8dc886f93d484f5c8d2449767.zip
kde-plasma/kwayland-integration: 5.26.90 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland-integration')
-rw-r--r--kde-plasma/kwayland-integration/Manifest1
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-5.26.90.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index 25eee61b62a4..23a404dcfac5 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -1,2 +1,3 @@
DIST kwayland-integration-5.25.5.tar.xz 24296 BLAKE2B 30fd0d0c2cb8ce34da692a40d558e7616796475f74ff7fc4212fdded88e7c55271836f160b48907fd3e195f41738c294e40c122bf51ec967861e17bc3d7de3bd SHA512 eabb2040275fd32b4ca1e8a5717a05589a331aac97e21861f36e8ac2b3c683b369d5f40507b0dbebd714dc766d311bd1233043327253e3c5d68de2464e12a342
DIST kwayland-integration-5.26.5.tar.xz 26972 BLAKE2B 108eeebc92768755fba22d7435829f514904a3f39c748a70f220c1ae4fa078d5def0921f6c96effc2c7cc1ae0580d8c251034e87acaf4107d340b7bfdac1e443 SHA512 de252e67f488f920538a15e69836d4b8779a3123e1913c78cb7d69833a8fa475eb1166928cc965bc7ad69aa26d3dc58395ac7d06fb2349120bd014939d81e229
+DIST kwayland-integration-5.26.90.tar.xz 25700 BLAKE2B b94d7c9381e87b092a6ed76e424228b2de0a1d5c7a1c6bb75f46b09a8ba5da15e66eee85e28bba52cc7822ac980af6e59ee80853c15ab6e9ec45543466538f24 SHA512 4dadc89b268199d79642c3b62cea1b7ce67eab47bbc88929f29dc33c712670a02db06f05790f45d5d699cc37a2605945cf8880b1c3c1c4442edfb6b15d07dcfd
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-5.26.90.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-5.26.90.ebuild
new file mode 100644
index 000000000000..6c04ca3dc173
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-5.26.90.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.102.0
+QTMIN=5.15.7
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module IdleTime
+ cmake_comment_add_subdirectory autotests # only contains idletime test
+ cmake_run_in src cmake_comment_add_subdirectory idletime
+}