summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-08-01 12:05:34 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-08-01 12:57:28 +0200
commit16398acd9df0c7a0e56c7dcc8d1cc984cad5fdde (patch)
treed8a8c75dae7081da33710fdf9469762afe6d6736 /kde-plasma/ksshaskpass
parentkde-plasma/kscreenlocker: 5.27.7 version bump (diff)
downloadgentoo-16398acd9df0c7a0e56c7dcc8d1cc984cad5fdde.tar.gz
gentoo-16398acd9df0c7a0e56c7dcc8d1cc984cad5fdde.tar.bz2
gentoo-16398acd9df0c7a0e56c7dcc8d1cc984cad5fdde.zip
kde-plasma/ksshaskpass: 5.27.7 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.27.7.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 1844e761e941..1d23df4c2682 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1 +1,2 @@
DIST ksshaskpass-5.27.6.tar.xz 28008 BLAKE2B 868fe8f1755429d06fa9bc44b7d086cd7ac25c0ec838c44287f96c00017380666b2fa2d536fb244381ccdd4a0fa81fcf8822d2b9c053efce03f8aa910f3272f1 SHA512 78d37b37b6ae4c8e8b5ee90bcb8e440140684f1cfa318eed98e854016dc22bbd7edc3036776f778e5bc46c2859f5a4f44f6af7293368f98cff48575a7e37d050
+DIST ksshaskpass-5.27.7.tar.xz 28040 BLAKE2B 0b757039d42f12118a6ce9f54343c600aab6bc90a87a54dafe30a0f4965e2f6b02b458e56dae90f04de2781e076f61a7b9dd93716b8d4ddd19b9ef6dbe3fa18c SHA512 981351d1d8e4de5a779b3d3c4908f7cdfb1b156efa33b5673c7f35aeda95e69d9da0c1a61af0c44dcfd4fd0f516070b838b7e7ec3ddd70e75b2d35f34e6594bb
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.27.7.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.27.7.ebuild
new file mode 100644
index 000000000000..1d6d755de2e8
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.27.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,} 2> /dev/null
+}