summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-23 22:09:13 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-23 22:18:21 +0100
commit2dee8b53681a4cc7231692f22a96b2f18a449961 (patch)
tree30f8675e686057904cbbc8941754ef70491a3983 /kde-plasma/kinfocenter
parentkde-plasma/khotkeys: 5.21.1 version bump (diff)
downloadgentoo-2dee8b53681a4cc7231692f22a96b2f18a449961.tar.gz
gentoo-2dee8b53681a4cc7231692f22a96b2f18a449961.tar.bz2
gentoo-2dee8b53681a4cc7231692f22a96b2f18a449961.zip
kde-plasma/kinfocenter: 5.21.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.21.1.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index ef6b7f509155..1bd3568ffcd3 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.20.5.tar.xz 1286404 BLAKE2B 3420e9d73e5cf73c91733fb3c72a4315db577ef5248e11036c4a6bdb1e897deb5983276ef903c25664ceba549cbad12bff2b6e6951abc90fbca0cc97e42c60ae SHA512 c7d2eb7307682f7bdc8ac22d1905dcc8bab0e258ee5f3458c4f40e43fee4d14ecd6b423f4357b338e05924db93d7c9914d3c36756620aac9fc6d0897ea4e5a90
DIST kinfocenter-5.21.0.tar.xz 1300796 BLAKE2B eacf7004ee65e5d889dd8733d5132c48f082104a28e8793b08b4faf8a72a524e3a9db4fe5556f36a278009f1ef55358c603e14a2749aebd9f7653946c09a84ad SHA512 b5e98235af9220b5994b968a27638b4a127dbe5cfdcf8ccc790c7a056a940cf49f2e8f32f6e0accfaf85980b13404ab9ec02f80745bf6c11ab0b99d857104cde
+DIST kinfocenter-5.21.1.tar.xz 1300748 BLAKE2B 5e5d110a2acd50a7fdd814dac69d9760945d27259623eda562764358958e5d4ad147d5ab1f4673d5b8e6a339b0bda62995d5dfb3e1c258f5ccb653fddacd91ac SHA512 98cd9a4323ff8738bc0fe35c69ddfaee6ddadf95a2b1e6995794481594c901c3a99ce1a44e5fe26a068948e03fd94b9d0491a285a606f0b1ed456b0ebed61387
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.21.1.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.21.1.ebuild
new file mode 100644
index 000000000000..27a3658cb7d1
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.21.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.78.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="gles2-only ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="wayland? ( || ( opengl gles2-only ) )"
+
+BDEPEND=">=dev-util/cmake-3.14.3"
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ x11-libs/libX11
+ gles2-only? ( media-libs/mesa[gles2] )
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ media-libs/mesa[X(+)]
+ !gles2-only? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? (
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ media-libs/mesa[egl]
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+ >=kde-plasma/systemsettings-${PVCUT}:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package ieee1394 RAW1394)
+ $(cmake_use_find_package pci PCIUTILS)
+ $(cmake_use_find_package wayland EGL)
+ $(cmake_use_find_package wayland KF5Wayland)
+ )
+
+ if has_version "dev-qt/qtgui[gles2-only]"; then
+ mycmakeargs+=( $(cmake_use_find_package gles2-only OpenGLES) )
+ else
+ mycmakeargs+=( $(cmake_use_find_package opengl OpenGL) )
+ fi
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Optional dependencies:"
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ fi
+ ecm_pkg_postinst
+}