summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-02-14 22:17:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-02-14 22:33:48 +0100
commitcac1603af8dc5d78b1c8ce524092650148bbdece (patch)
treeea79bc0ffd88e6adc451e20e5c8bf0f7eaa91a93 /kde-frameworks/syntax-highlighting
parentkde-frameworks/sonnet: 5.91.0 version bump (diff)
downloadgentoo-cac1603af8dc5d78b1c8ce524092650148bbdece.tar.gz
gentoo-cac1603af8dc5d78b1c8ce524092650148bbdece.tar.bz2
gentoo-cac1603af8dc5d78b1c8ce524092650148bbdece.zip
kde-frameworks/syntax-highlighting: 5.91.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/syntax-highlighting')
-rw-r--r--kde-frameworks/syntax-highlighting/Manifest1
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.91.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/Manifest b/kde-frameworks/syntax-highlighting/Manifest
index 1a7a3eea5382..2c1b51c6cbb5 100644
--- a/kde-frameworks/syntax-highlighting/Manifest
+++ b/kde-frameworks/syntax-highlighting/Manifest
@@ -1 +1,2 @@
DIST syntax-highlighting-5.90.0.tar.xz 2392656 BLAKE2B 5e297123f30bcb1a282501fbc13a8cdeb3c58528b1ba0d58838d742339c8786b68d8ccad6753e582335eccb2085e477eaac012bbf80047fbe1a7cef4d9e57ddc SHA512 4a2d4b88fc55963d18d8cf6a6be668256f39c7cd3b74468058e1b21e91a972306ccb8de0bd441bf8f23c926ecdf48af7ea97df79af8076b5a52045b331e8bc03
+DIST syntax-highlighting-5.91.0.tar.xz 2394684 BLAKE2B 1c1f35b5e1a7bf95e53e7b087673d27a8a66b20b1e5289c241ebd80fd84a698388cc27b48f7fb9f7731bfc45d3197710b3a341ab56ba7c33d6f706e737c56c41 SHA512 9d891f4a40df757d432639fce86374661a088a7b488f2f4515db783cca727b49bec65f558f5b8892b2149f8f9d7dcab7172d10766dadd959eadc4fcad9f50c39
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.91.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.91.0.ebuild
new file mode 100644
index 000000000000..437ce41a3321
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.91.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="nls"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-lang/perl
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+
+src_install() {
+ ecm_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}