summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-31 20:45:35 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-01 22:17:06 +0100
commit327cc052e9020fa04f782f291889abab8ba6e9a7 (patch)
tree196dd0b288c94b4665d97ce77825772b5b102e62 /kde-frameworks/frameworkintegration
parentprofiles: Mask KDE Frameworks 5.249 (diff)
downloadgentoo-327cc052e9020fa04f782f291889abab8ba6e9a7.tar.gz
gentoo-327cc052e9020fa04f782f291889abab8ba6e9a7.tar.bz2
gentoo-327cc052e9020fa04f782f291889abab8ba6e9a7.zip
kde-frameworks/frameworkintegration: 5.249.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.249.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 07f487a2b142..2f8dd236e38b 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,3 +1,4 @@
DIST frameworkintegration-5.113.0.tar.xz 1760432 BLAKE2B f8289c33889cf8bafd51b1db44efba93d9b580a9cd69be69e2fadd957a2db728d0c981da5af4c8b4be264fc3af8b7b44d6be0e144dc2a596a601cfc35f1d6274 SHA512 a9fe7a6c262482cb8b8d392064f66413a03d2bd031263470b0bbef1466bc18749d874d93c4c637958fecc72d7ec9273eabb3d48a0d7c457533c1ea7caf419e90
DIST frameworkintegration-5.114.0.tar.xz 1760452 BLAKE2B 95b6ad13e185887e07ef04ba1eb696aac2d1ead3ff3b2d270044a07314b8532d5244ed23548582db852ae88b96fcbce728de6cc6fa4ccfe5467cfcc96ef1c953 SHA512 257d8b216053583c40a7586588f3ca0dff35e6240d1f222cfddc4c61c6c085a4e1ebde5a1a4bb59210db999a9fd932c3614cf8bcab6d40127413c0dc7f163e67
DIST frameworkintegration-5.248.0.tar.xz 54248 BLAKE2B 620b61128859bedc8cc2ed1aa8e0b349d93b59749ae8a2fd6f7517d9c68f6cdf3e47b7baba959a0fb30d1ae9e0c7444da9d4a9b5eabe2f4fe483fa922e258b93 SHA512 fae603dd539e522383424f72aa9deeae842ed5c6e037185d3da5292d5df6aa5c7a6694c0ed84f5cb74133918d03160cff417f525c203b7e406591b395c7eea3b
+DIST frameworkintegration-5.249.0.tar.xz 54200 BLAKE2B 34474f4b5cbe4a12b509591b477fb0db184bec60af7e0e4d6b53e2c4ed3cb54dc172b31810fb206aedf69aa9a6a3169c3000557ff06357bc261aee2d92109f98 SHA512 3f34f837481bb473075e4ab45dbe125015e88e7b03e5c785bb31926afec37ca2677b99e0ce16672120054f9007f1d668cfe95001c99fb7d40878986882c6d797
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.249.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.249.0.ebuild
new file mode 100644
index 000000000000..134bdbb27a35
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.249.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.0
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
+ =kde-frameworks/kcolorscheme-${PVCUT}*:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kiconthemes-${PVCUT}*:6
+ =kde-frameworks/knewstuff-${PVCUT}*:6
+ =kde-frameworks/knotifications-${PVCUT}*:6
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:6
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:6
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt6=ON
+ )
+
+ ecm_src_configure
+}