summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-08-26 12:51:53 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-08-26 13:00:30 +0200
commit0ddd7ebfc0f6e414b86701d69bc902d35d495704 (patch)
tree36fe074659546ef7057667da53207e148f48d03c /kde-apps/yakuake
parentprofiles/package.mask: mask dev-ruby/state_machine for removal (diff)
downloadgentoo-0ddd7ebfc0f6e414b86701d69bc902d35d495704.tar.gz
gentoo-0ddd7ebfc0f6e414b86701d69bc902d35d495704.tar.bz2
gentoo-0ddd7ebfc0f6e414b86701d69bc902d35d495704.zip
kde-apps/yakuake: Fix cmake w/ IUSE=-absolute-position
See also: https://invent.kde.org/utilities/yakuake/-/merge_requests/111 Bug: https://bugs.gentoo.org/904742 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/yakuake')
-rw-r--r--kde-apps/yakuake/files/yakuake-23.08.0-cmake.patch28
-rw-r--r--kde-apps/yakuake/yakuake-23.08.0.ebuild2
2 files changed, 30 insertions, 0 deletions
diff --git a/kde-apps/yakuake/files/yakuake-23.08.0-cmake.patch b/kde-apps/yakuake/files/yakuake-23.08.0-cmake.patch
new file mode 100644
index 000000000000..808aa488d0da
--- /dev/null
+++ b/kde-apps/yakuake/files/yakuake-23.08.0-cmake.patch
@@ -0,0 +1,28 @@
+From 0d0a3639b1c1e33aa49e979879e29064808a0a96 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 26 Aug 2023 12:49:24 +0200
+Subject: [PATCH] Fix broken HAVE_KWAYLAND assignment
+
+Fixes up commit 3e58132f2315b99d0d8c8c233a8183079356506a
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2d143f9..bfdcd12 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -80,7 +80,7 @@ if(NOT APPLE)
+ endif()
+
+ find_package(KF${KF_MAJOR_VERSION}Wayland ${KF_MIN_VERSION} CONFIG)
+- set(HAVE_KWAYLAND KF${KF_MAJOR_VERSION}Wayland_FOUND)
++ set(HAVE_KWAYLAND ${KF${KF_MAJOR_VERSION}Wayland_FOUND})
+ endif()
+
+ add_subdirectory(app)
+--
+2.42.0
+
diff --git a/kde-apps/yakuake/yakuake-23.08.0.ebuild b/kde-apps/yakuake/yakuake-23.08.0.ebuild
index e26baa415e5c..dde091307229 100644
--- a/kde-apps/yakuake/yakuake-23.08.0.ebuild
+++ b/kde-apps/yakuake/yakuake-23.08.0.ebuild
@@ -47,6 +47,8 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package absolute-position KF5Wayland)