summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-12 19:24:29 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-12 19:24:41 +0100
commit2066cf7b5a1da5ded50affbdc96467b431140f3e (patch)
treeeec619c4a351b2aa2376ea6f0d543086f9b9c747 /kde-apps/akonadi-contacts
parentdev-python/bandit: bup (diff)
downloadgentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.tar.gz
gentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.tar.bz2
gentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.zip
kde-apps: Version bump KDE Applications 16.12.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps/akonadi-contacts')
-rw-r--r--kde-apps/akonadi-contacts/Manifest1
-rw-r--r--kde-apps/akonadi-contacts/akonadi-contacts-16.12.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-apps/akonadi-contacts/Manifest b/kde-apps/akonadi-contacts/Manifest
index 3896ccc7194c..f45202463f1c 100644
--- a/kde-apps/akonadi-contacts/Manifest
+++ b/kde-apps/akonadi-contacts/Manifest
@@ -1 +1,2 @@
DIST akonadi-contacts-16.12.0.tar.xz 149280 SHA256 ecef2db9caa240d917e7a645597fe6d833dade77795e1efd18533f74f8d8b1c6 SHA512 b275c772b0c1eb040b4855437fcf91a47395010261314926c6d1bcfad6152d356fedff42351e741befdc72f14b4dd7d7219608afa16d1e20bf9666e643f846be WHIRLPOOL 5e8cd2a5abe1bb91451025791b28febb4c0e8a23cb03dae3388ba599024719ff14cb4f2b0640c427dfeb39fd5146d62ae08f5b67cb0884885740b10cf2c990bf
+DIST akonadi-contacts-16.12.1.tar.xz 149284 SHA256 799e72e988132cfa26b13d3a534ec807742541d57e794ff3934621bd6d255510 SHA512 56429472e9dbbc10cfe5d858eca515add0b6c581a485fdd756cd5e43af4561dced305d990454dcf42a5cda0dcef264298c0facc4ac9827ee99d8d06068dccd39 WHIRLPOOL f19d0e5b82643ad3602f8576ab5295d3db61774f9effe4e11134b08c62293ce6e8c2bc0887f6339b555bad4d61f8934bc63d2ce05bd42f2c6e798dbea3d0bfc4
diff --git a/kde-apps/akonadi-contacts/akonadi-contacts-16.12.1.ebuild b/kde-apps/akonadi-contacts/akonadi-contacts-16.12.1.ebuild
new file mode 100644
index 000000000000..184c812665e0
--- /dev/null
+++ b/kde-apps/akonadi-contacts/akonadi-contacts-16.12.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for akonadi contact integration"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+IUSE="prison"
+
+# some akonadi tests time out, that probably needs more work as it's ~700 tests
+RESTRICT+=" test"
+
+DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kmime)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ >=dev-libs/grantlee-5.1.0:5
+ prison? ( $(add_frameworks_dep prison) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package prison KF5Prison)
+ )
+
+ kde5_src_configure
+}