summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-09-19 19:52:47 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-09-19 22:48:51 +0200
commitd9fdc8ff1432ea7105cdbe992caf9cb1a66a84d0 (patch)
tree69afe628aea928e81043440ccdb77ca04ff88ed0 /gnustep-base
parentgnustep-apps/talksoup: EAPI8 bump, fix LICENSE (diff)
downloadgentoo-d9fdc8ff1432ea7105cdbe992caf9cb1a66a84d0.tar.gz
gentoo-d9fdc8ff1432ea7105cdbe992caf9cb1a66a84d0.tar.bz2
gentoo-d9fdc8ff1432ea7105cdbe992caf9cb1a66a84d0.zip
gnustep-base/gnustep-back-art: EAPI8 bump, fix LICENSE
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-back-art/gnustep-back-art-0.29.0.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/gnustep-base/gnustep-back-art/gnustep-back-art-0.29.0.ebuild b/gnustep-base/gnustep-back-art/gnustep-back-art-0.29.0.ebuild
index a76c50f385c3..b082712bb764 100644
--- a/gnustep-base/gnustep-back-art/gnustep-back-art-0.29.0.ebuild
+++ b/gnustep-base/gnustep-back-art/gnustep-back-art-0.29.0.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit gnustep-base
-DESCRIPTION="libart_lgpl back-end component for the GNUstep GUI Library"
+DESCRIPTION="Libart_lgpl back-end component for the GNUstep GUI Library"
HOMEPAGE="https://gnustep.github.io"
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
+S="${WORKDIR}/gnustep-back-${PV}"
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="opengl xim"
@@ -34,7 +36,11 @@ RDEPEND="${GNUSTEP_CORE_DEPEND}
!gnustep-base/gnustep-back-xlib"
DEPEND="${RDEPEND}"
-S=${WORKDIR}/gnustep-back-${PV}
+src_prepare() {
+ default
+ # do not compress man pages
+ sed -i '/which gzip/,/&& gzip/d' Tools/GNUmakefile.postamble || die
+}
src_configure() {
egnustep_env
@@ -68,8 +74,8 @@ src_compile() {
src_install() {
gnustep-base_src_install
- mkdir -p "${D}/${GNUSTEP_SYSTEM_LIBRARY}/Fonts"
- cp -pPR Fonts/*.nfont "${D}/${GNUSTEP_SYSTEM_LIBRARY}/Fonts"
+ mkdir -p "${D}/${GNUSTEP_SYSTEM_LIBRARY}/Fonts" || die
+ cp -pPR Fonts/*.nfont "${D}/${GNUSTEP_SYSTEM_LIBRARY}/Fonts" || die
}
gnustep_config_script() {