summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-05 08:25:31 +0000
committerSam James <sam@gentoo.org>2023-12-05 10:32:03 +0000
commit00e05500046932b17d5bf1a7c8b1ccef1f2b50f6 (patch)
treed569510ff6723165900771f6e7170092ba860514 /gnome-extra
parenteclass/(dist-)kernel{-utils,-install}: More flexible initrd generation (diff)
downloadgentoo-00e05500046932b17d5bf1a7c8b1ccef1f2b50f6.tar.gz
gentoo-00e05500046932b17d5bf1a7c8b1ccef1f2b50f6.tar.bz2
gentoo-00e05500046932b17d5bf1a7c8b1ccef1f2b50f6.zip
gnome-extra/zenity: add 3.99.91
Closes: https://bugs.gentoo.org/919083 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/zenity/Manifest1
-rw-r--r--gnome-extra/zenity/zenity-3.99.91.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/gnome-extra/zenity/Manifest b/gnome-extra/zenity/Manifest
index e8871af557d7..5a39f5d67e9c 100644
--- a/gnome-extra/zenity/Manifest
+++ b/gnome-extra/zenity/Manifest
@@ -1,3 +1,4 @@
DIST zenity-3.44.2.tar.xz 3095752 BLAKE2B 07d5b9aa673ae1e719bbd8d2ff85394ce19b9e77c36c3b6cf73d6b806dbcb0ab6322d13e66a715ebf5aefc14fa289a31367d0f0abd6ceaa9df7e3d7d12049492 SHA512 60f139b18db9ddf95a9c3481b08a3b99dd56ce457a49d99dc33f59570837e8498e8819bdd130c915a08e40042b2f3af583bd0fe4498adb8152632bd044137f2f
DIST zenity-3.99.2.tar.xz 3084880 BLAKE2B a6ae2a465516f2e019ad5bec5a4f5bad42dc499f85e5f293804d18c572a3f2dd69224ceb6dfc62156aaff587d8a4e78549e8cc88493c842a6ad056ce58c85920 SHA512 6130c01e34e74bd6d068cbd6d3c1e208fce73cbce61851482e0dbc5c24322953899b6de7859ed86fe89850a1650ad28f8815cf709c152c02a685725350260afb
DIST zenity-3.99.90.tar.xz 3086228 BLAKE2B 7254447125019b309ef3466fd6f7fc935968395dbd4d506b69a8b80ea4e8150620f6e0647265dcb2023f9f28bb59a84d174d8563f4a9ba0a3598489931070e79 SHA512 7f1dbf9baa6960059eb7e973b175a2b4411b695d211fb3fc290bd393a75cdb201a440adb05fbe7f6a1d162d3b80a409c3b64573abb037b047a9a8c27c981e9a1
+DIST zenity-3.99.91.tar.xz 3086032 BLAKE2B fc1bddfbf0462768438a52ab738a921603054a78a139b12fb516e8c9640d1039776614cef266092843b8c14bb856f3d704414dd5e07abe686bf7dbfbf08e4a7a SHA512 face2f4ca11dd9b3ab56995e7777fe6db7bd209494019d1454eab8813a537971eb5b229103374a85e7324229357b7f1723508a0a1e263ec05ac4a99c7c0eb3a9
diff --git a/gnome-extra/zenity/zenity-3.99.91.ebuild b/gnome-extra/zenity/zenity-3.99.91.ebuild
new file mode 100644
index 000000000000..1f8292d3f4ef
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.99.91.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="man webkit"
+
+# TODO: X11 dependency is automagically enabled
+RDEPEND="
+ >=gui-libs/libadwaita-1.2:1
+ webkit? ( >=net-libs/webkit-gtk-2.40.1:6 )
+ man? ( sys-apps/help2man )
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use webkit webkitgtk)
+ $(meson_use man manpage)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}