summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-12-31 00:12:59 +0200
committerMart Raudsepp <leio@gentoo.org>2019-12-31 00:36:04 +0200
commite41d7ddd80a0688e8eac70455fc9bf6d0d85ae9b (patch)
tree3d388fd84eae0a5c80f6727c70546f5a58b4ffff /gnome-extra/zenity
parentsys-boot/raspberrypi-firmware: add ~arm64 keyword (diff)
downloadgentoo-e41d7ddd80a0688e8eac70455fc9bf6d0d85ae9b.tar.gz
gentoo-e41d7ddd80a0688e8eac70455fc9bf6d0d85ae9b.tar.bz2
gentoo-e41d7ddd80a0688e8eac70455fc9bf6d0d85ae9b.zip
gnome-extra/zenity: bump to 3.32.0
Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra/zenity')
-rw-r--r--gnome-extra/zenity/Manifest1
-rw-r--r--gnome-extra/zenity/zenity-3.32.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/gnome-extra/zenity/Manifest b/gnome-extra/zenity/Manifest
index 5deb4a27e14a..9a98b4bd3d57 100644
--- a/gnome-extra/zenity/Manifest
+++ b/gnome-extra/zenity/Manifest
@@ -1 +1,2 @@
DIST zenity-3.30.0.tar.xz 4485332 BLAKE2B b7dba31693849222f1a01a037a271e20d4ca58d51247635559f66e2afa848f9861b3c6e435d18a882d81263dac02d96e6673774131bb6ccf6d1f8c32dbb2aa40 SHA512 f80aa6c4fb0726bd4db1010dc3b6ca89476272cd4b852c04225bc9e2dc365ec34f6a55f0cfca474abcfba4d28dc47b72f81e8b3c447c0f99e843251c84807432
+DIST zenity-3.32.0.tar.xz 4753752 BLAKE2B 220fbd374f2564b345f4668c0583f2678a296bbb0d344af55b849b4e7e718f29856bd43f7ae2b0fa492e3d1d8180ca160236fcc806cd483716f680d03aa019d0 SHA512 d057df25dbb2d780c6be184ec167b0f569eadf0ac1c460d63509843157f14dfdcebe46bb6f93b17c6069ef0208902ce9ecbb4025933f7dc7572323032ec34fda
diff --git a/gnome-extra/zenity/zenity-3.32.0.ebuild b/gnome-extra/zenity/zenity-3.32.0.ebuild
new file mode 100644
index 000000000000..a22518e62371
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.32.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug libnotify webkit"
+
+# TODO: X11 dependency is automagically enabled
+RDEPEND="
+ >=dev-libs/glib-2.8:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3:3[X]
+ x11-libs/libX11
+ x11-libs/pango
+ libnotify? ( >=x11-libs/libnotify-0.6.1:= )
+ webkit? ( >=net-libs/webkit-gtk-2.8.1:4 )
+"
+DEPEND="${RDEPEND}
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable libnotify) \
+ $(use_enable webkit webkitgtk) \
+ PERL=$(type -P false)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Not really needed and prevent us from needing perl
+ rm "${ED}/usr/bin/gdialog" || die "rm gdialog failed!"
+}