summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-03-28 21:38:16 +0200
committerPacho Ramos <pacho@gentoo.org>2021-03-28 21:38:26 +0200
commit3c4543b514126e229512e4a530a10bfd8ed89f4f (patch)
treec72ffb2ad73a499883587ad5aa29826fbd6a342c /gnome-extra/gnome-shell-extension-gsconnect
parentapp-emacs/filladapt: Fix byte-compilation with Emacs 27 (diff)
downloadgentoo-3c4543b514126e229512e4a530a10bfd8ed89f4f.tar.gz
gentoo-3c4543b514126e229512e4a530a10bfd8ed89f4f.tar.bz2
gentoo-3c4543b514126e229512e4a530a10bfd8ed89f4f.zip
gnome-extra/gnome-shell-extension-gsconnect: Bump to v45
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-shell-extension-gsconnect')
-rw-r--r--gnome-extra/gnome-shell-extension-gsconnect/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-gsconnect/gnome-shell-extension-gsconnect-45.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-gsconnect/Manifest b/gnome-extra/gnome-shell-extension-gsconnect/Manifest
index c38daa8d89bd..9cb05076ea83 100644
--- a/gnome-extra/gnome-shell-extension-gsconnect/Manifest
+++ b/gnome-extra/gnome-shell-extension-gsconnect/Manifest
@@ -1,2 +1,3 @@
DIST gnome-shell-extension-gsconnect-42.tar.gz 729438 BLAKE2B 19aea0008487c5c316a6883da176ccba4bf31334abe1ce273cdba91d4fbacfa8a3e003909488e957486ea371043174eefd1ca990470f99ac4ff36ff73cd498cc SHA512 27965435ef9524021e3ce3825af73d9a8b7f602d8c73b524bcf247b6af47ad14b16e83815b1a30e148b109531fbe230e531e1a0b456f5f51c9c96a4c5a3b19a5
DIST gnome-shell-extension-gsconnect-44.tar.gz 731896 BLAKE2B f4d51ca366bf6a3fe65713da516331a5e3beba19ed6fa22b7224be3c05433bdc125d80e04ac3a1da966ed4f671c6771a53b0cd3f94f7c81eea51f8a30415a5d6 SHA512 92ca5750772c64300c4b8760d4202a1e27d5e7f0fedc5672fd54b48e17de095b29fe0ce18df76619a2e3e3802bb4b77ffdc98b9b4987db3e9550251a61f8b832
+DIST gnome-shell-extension-gsconnect-45.tar.gz 735089 BLAKE2B 44704b0a32d68c123581818f0e8e6bc429fc9be462c98addb98980ef19eefbfce0618c718e640a8bed1c60500f796dc31c4d74c8394a940bf6ecfa7644eccf45 SHA512 59b81316ff02116bf92525acf21a99152b15417459d42be4c710a25d879a326cc3f03a9c0595fa9879e2abd613d4acb067d340bc60c8a80bf88909ea7269903e
diff --git a/gnome-extra/gnome-shell-extension-gsconnect/gnome-shell-extension-gsconnect-45.ebuild b/gnome-extra/gnome-shell-extension-gsconnect/gnome-shell-extension-gsconnect-45.ebuild
new file mode 100644
index 000000000000..b82245ebb2cb
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-gsconnect/gnome-shell-extension-gsconnect-45.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils meson readme.gentoo-r1 xdg
+
+DESCRIPTION="KDE Connect implementation for Gnome Shell"
+HOMEPAGE="https://github.com/andyholmes/gnome-shell-extension-gsconnect"
+SRC_URI="https://github.com/andyholmes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nautilus"
+
+COMMON_DEPEND="dev-libs/glib:2"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=dev-libs/gjs-1.48
+ =gnome-base/gnome-shell-3.38*
+ gnome-base/gvfs
+ gnome-extra/evolution-data-server
+ || ( media-libs/libcanberra media-libs/gsound )
+ nautilus? (
+ dev-python/nautilus-python
+ gnome-base/nautilus[introspection] )
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="For knowing more about how to do the setup, please visit:
+https://github.com/andyholmes/gnome-shell-extension-gsconnect/wiki/Installation"
+
+src_configure() {
+ # nemo support relies on nemo-python from https://github.com/linuxmint/nemo-extensions
+ # https://bugs.gentoo.org/694388
+ meson_src_configure \
+ -Dinstalled_tests=false \
+ -Dnemo=false \
+ $(meson_use nautilus)
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}