summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-08-22 15:10:31 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-08-22 15:11:53 +0200
commitbae9991bf1f8354a70841bd292036160e5120e7a (patch)
treee6db3d9d6a3389857c7bd54f7e8de90caf947b26 /games-strategy
parentmedia-libs/opencv: add 4.8.0 (diff)
downloadgentoo-bae9991bf1f8354a70841bd292036160e5120e7a.tar.gz
gentoo-bae9991bf1f8354a70841bd292036160e5120e7a.tar.bz2
gentoo-bae9991bf1f8354a70841bd292036160e5120e7a.zip
games-strategy/0ad: add upstream gcc13 patch
Closes: https://bugs.gentoo.org/912362 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/0ad/0ad-0.0.26_alpha.ebuild4
-rw-r--r--games-strategy/0ad/files/0ad-0.0.26_alpha-add-missing-cstdint-include.patch29
2 files changed, 32 insertions, 1 deletions
diff --git a/games-strategy/0ad/0ad-0.0.26_alpha.ebuild b/games-strategy/0ad/0ad-0.0.26_alpha.ebuild
index c440f50e1334..49d734e318bd 100644
--- a/games-strategy/0ad/0ad-0.0.26_alpha.ebuild
+++ b/games-strategy/0ad/0ad-0.0.26_alpha.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2014-2022 Gentoo Authors
+# Copyright 2014-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -97,6 +97,8 @@ RDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-0.0.24b_alpha-respect-tc.patch
"${FILESDIR}"/${PN}-0.0.25b_alpha-fix-setuptools.patch
+ # https://code.wildfiregames.com/D4997
+ "${FILESDIR}"/${P}-add-missing-cstdint-include.patch
)
pkg_setup() {
diff --git a/games-strategy/0ad/files/0ad-0.0.26_alpha-add-missing-cstdint-include.patch b/games-strategy/0ad/files/0ad-0.0.26_alpha-add-missing-cstdint-include.patch
new file mode 100644
index 000000000000..db3fe2ebfc09
--- /dev/null
+++ b/games-strategy/0ad/files/0ad-0.0.26_alpha-add-missing-cstdint-include.patch
@@ -0,0 +1,29 @@
+diff --git a/source/tools/atlas/GameInterface/Messages.h b/source/tools/atlas/GameInterface/Messages.h
+index 2fa4780..a486d93 100644
+--- a/source/tools/atlas/GameInterface/Messages.h
++++ b/source/tools/atlas/GameInterface/Messages.h
+@@ -1,4 +1,4 @@
+-/* Copyright (C) 2022 Wildfire Games.
++/* Copyright (C) 2023 Wildfire Games.
+ * This file is part of 0 A.D.
+ *
+ * 0 A.D. is free software: you can redistribute it and/or modify
+@@ -18,13 +18,15 @@
+ #ifndef INCLUDED_MESSAGES
+ #define INCLUDED_MESSAGES
+
++#include <cstdint>
++#include <string>
++#include <vector>
++
++// Opens namespace AtlasMessage, closes it on second inclusion!
+ #ifndef MESSAGES_SKIP_SETUP
+ #include "MessagesSetup.h"
+ #endif
+
+-#include <vector>
+-#include <string>
+-
+ // TODO: organisation, documentation, etc
+
+ #ifdef _MSC_VER // (can't use MSC_VERSION here since this file is included by Atlas too)