summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-11 21:08:47 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-11 21:16:00 -0400
commitcdcfeb1855998c43033042d3980d38f5f695bd91 (patch)
treed067f54247af263e35be926a6f1f692ab1e8788e /games-simulation
parentdev-games/simgear: use https for git clones in live (diff)
downloadgentoo-cdcfeb1855998c43033042d3980d38f5f695bd91.tar.gz
gentoo-cdcfeb1855998c43033042d3980d38f5f695bd91.tar.bz2
gentoo-cdcfeb1855998c43033042d3980d38f5f695bd91.zip
games-simulation/flightgear: mark as LTO-unsafe
Closes: https://bugs.gentoo.org/859217 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/flightgear/flightgear-2020.3.19.ebuild7
-rw-r--r--games-simulation/flightgear/flightgear-9999.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/games-simulation/flightgear/flightgear-2020.3.19.ebuild b/games-simulation/flightgear/flightgear-2020.3.19.ebuild
index fffe97177e82..9d6373a47ddb 100644
--- a/games-simulation/flightgear/flightgear-2020.3.19.ebuild
+++ b/games-simulation/flightgear/flightgear-2020.3.19.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake toolchain-funcs
+inherit cmake flag-o-matic toolchain-funcs
DESCRIPTION="Open Source Flight Simulator"
HOMEPAGE="https://www.flightgear.org/"
@@ -79,6 +79,11 @@ pkg_setup() {
}
src_configure() {
+ # -Werror=lto-type-mismatch, -Werror=odr
+ # https://bugs.gentoo.org/859217
+ # https://sourceforge.net/p/flightgear/codetickets/2908/
+ filter-lto
+
local mycmakeargs=(
-DBUILD_SHARED_LIBS=OFF
-DENABLE_AUTOTESTING=OFF
diff --git a/games-simulation/flightgear/flightgear-9999.ebuild b/games-simulation/flightgear/flightgear-9999.ebuild
index ec1215fc6d90..720c1042bbd6 100644
--- a/games-simulation/flightgear/flightgear-9999.ebuild
+++ b/games-simulation/flightgear/flightgear-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake toolchain-funcs git-r3
+inherit cmake flag-o-matic toolchain-funcs git-r3
DESCRIPTION="Open Source Flight Simulator"
HOMEPAGE="https://www.flightgear.org/"
@@ -80,6 +80,11 @@ pkg_setup() {
}
src_configure() {
+ # -Werror=lto-type-mismatch, -Werror=odr
+ # https://bugs.gentoo.org/859217
+ # https://sourceforge.net/p/flightgear/codetickets/2908/
+ filter-lto
+
local mycmakeargs=(
-DBUILD_SHARED_LIBS=OFF
-DENABLE_AUTOTESTING=OFF