summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-10-27 13:47:19 -0500
committerAustin English <wizardedit@gentoo.org>2016-10-27 13:55:01 -0500
commita9ad9aca0eadec6dc64e418d7e2c446854a3dd10 (patch)
treec5febfe4a90c837d5806f561eabe53eb7de99905 /games-rpg
parentsys-libs/libapparmor: remove old (diff)
downloadgentoo-a9ad9aca0eadec6dc64e418d7e2c446854a3dd10.tar.gz
gentoo-a9ad9aca0eadec6dc64e418d7e2c446854a3dd10.tar.bz2
gentoo-a9ad9aca0eadec6dc64e418d7e2c446854a3dd10.zip
games-rpg/wastesedge: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.2
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/wastesedge/wastesedge-0.3.5-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-rpg/wastesedge/wastesedge-0.3.5-r1.ebuild b/games-rpg/wastesedge/wastesedge-0.3.5-r1.ebuild
new file mode 100644
index 000000000000..bf6b95b394d7
--- /dev/null
+++ b/games-rpg/wastesedge/wastesedge-0.3.5-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1
+
+DESCRIPTION="role playing game to showcase the adonthell engine"
+HOMEPAGE="http://adonthell.linuxgames.com/"
+SRC_URI="https://savannah.nongnu.org/download/adonthell/${PN}-src-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+RESTRICT="userpriv"
+
+RDEPEND="${PYTHON_DEPS}
+ >=games-rpg/adonthell-0.3.5-r2[${PYTHON_USEDEP}]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_configure(){
+ econf \
+ $(use_enable nls) \
+ --with-adonthell-binary="/usr/bin/adonthell"
+}
+
+src_install(){
+ emake DESTDIR="${D}" pixmapdir=/usr/share/pixmaps install
+ dodoc AUTHORS ChangeLog NEWS PLAYING README
+ make_desktop_entry adonthell-wastesedge "Waste's Edge" wastesedge_32x32
+}