summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-14 12:58:10 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-14 14:12:31 -0500
commit42e57095abb17358641a544e084891bd98c64061 (patch)
treeb9a64b8abde73012726071b4a032a838b249f1a6 /games-roguelike
parentgames-roguelike/mazesofmonad: remove deprecated games eclass (diff)
downloadgentoo-42e57095abb17358641a544e084891bd98c64061.tar.gz
gentoo-42e57095abb17358641a544e084891bd98c64061.tar.bz2
gentoo-42e57095abb17358641a544e084891bd98c64061.zip
games-roguelike/powder: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/powder/powder-117-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-roguelike/powder/powder-117-r1.ebuild b/games-roguelike/powder/powder-117-r1.ebuild
new file mode 100644
index 000000000000..f0d8cd23b249
--- /dev/null
+++ b/games-roguelike/powder/powder-117-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit flag-o-matic
+
+MY_P=${P/-/}_src
+
+DESCRIPTION="A game in the genre of Rogue, Nethack, and Diablo. Emphasis is on tactical play"
+HOMEPAGE="http://www.zincland.com/powder/"
+SRC_URI="http://www.zincland.com/powder/release/${MY_P}.tar.gz"
+
+LICENSE="CC-Sampling-Plus-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ append-cxxflags -DCHANGE_WORK_DIRECTORY
+ emake -C port/linux premake
+ emake -C port/linux powder
+}
+
+src_install() {
+ dobin port/linux/${PN}
+ dodoc README.TXT CREDITS.TXT
+}
+
+pkg_postinst() {
+ elog "While the highscore is kept, save games are never preserved between"
+ elog "versions. Please wait until your current character dies before upgrading."
+}