summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/magiccube4d
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/magiccube4d')
-rw-r--r--games-puzzle/magiccube4d/Manifest1
-rw-r--r--games-puzzle/magiccube4d/files/magiccube4d-2.2-64bit-ptr.patch53
-rw-r--r--games-puzzle/magiccube4d/files/magiccube4d-2.2-gcc41.patch22
-rw-r--r--games-puzzle/magiccube4d/files/magiccube4d-2.2-ldflags.patch15
-rw-r--r--games-puzzle/magiccube4d/files/magiccube4d-EventHandler.patch11
-rw-r--r--games-puzzle/magiccube4d/magiccube4d-2.2.ebuild42
-rw-r--r--games-puzzle/magiccube4d/metadata.xml5
7 files changed, 149 insertions, 0 deletions
diff --git a/games-puzzle/magiccube4d/Manifest b/games-puzzle/magiccube4d/Manifest
new file mode 100644
index 000000000000..5959168118b5
--- /dev/null
+++ b/games-puzzle/magiccube4d/Manifest
@@ -0,0 +1 @@
+DIST mc4d-src-2_2.tgz 144645 SHA256 79c7b62bbe7a132a2eacf58f92f80113ea63171d3eea59755bc828a1aa9daa44 SHA512 19491460bada93b4ee2010004128279cb88ab866a5a8c791080d59fa86e5bacf966d7dab0c9b3074e94b77611ae341480d19b384079e83df549ef25e592b12a6 WHIRLPOOL 9413fc099375eaf1c5bfdba15e9836125c37275cf0be47560b8d4b99c7a3008393787e2037d91b8b4f8075cf7c3c408a84c111f43d3378f2bd780e8ee35137dc
diff --git a/games-puzzle/magiccube4d/files/magiccube4d-2.2-64bit-ptr.patch b/games-puzzle/magiccube4d/files/magiccube4d-2.2-64bit-ptr.patch
new file mode 100644
index 000000000000..7fbd52871887
--- /dev/null
+++ b/games-puzzle/magiccube4d/files/magiccube4d-2.2-64bit-ptr.patch
@@ -0,0 +1,53 @@
+diff -Nru magiccube4d-src-2_2.orig/EventHandler.cpp magiccube4d-src-2_2/EventHandler.cpp
+--- magiccube4d-src-2_2.orig/EventHandler.cpp 2007-09-30 12:01:46.503967712 +0200
++++ magiccube4d-src-2_2/EventHandler.cpp 2007-09-30 12:03:23.489172011 +0200
+@@ -20,6 +20,7 @@
+ #include <iostream>
+ #include <unistd.h>
+ #include <stdio.h>
++#include <stdint.h>
+
+ #include "MagicCube.h"
+ #include "Puzzlest.h"
+@@ -415,7 +416,7 @@
+ void
+ EventHandler::undo_cb(void* argp)
+ {
+- int arg = (int) argp;
++ int arg = (intptr_t) argp;
+ struct stickerspec grip;
+ int dir;
+ int slicesmask;
+@@ -461,7 +462,7 @@
+ void
+ EventHandler::redo_cb(void* argp)
+ {
+- int arg = (int) argp;
++ int arg = (intptr_t) argp;
+ struct stickerspec grip;
+ int dir;
+ int slicesmask;
+@@ -507,7 +508,7 @@
+ void
+ EventHandler::scramble_cb(void *arg = NULL)
+ {
+- int n = (int)arg;
++ int n = (intptr_t)arg;
+ struct stickerspec grip;
+ int i, previous_face = -1;
+ int ngrips = NFACES * 3 * 3 * 3;
+@@ -855,12 +856,12 @@
+ void
+ EventHandler::newPuzzle_cb(void* arg)
+ {
+- if ((int)arg == preferences.getLength())
++ if ((intptr_t)arg == preferences.getLength())
+ {
+ reset_cb(0);
+ return;
+ }
+- preferences.setLength((int)arg);
++ preferences.setLength((intptr_t)arg);
+ int length = preferences.getLength();
+
+ polymgr->reset(length);
diff --git a/games-puzzle/magiccube4d/files/magiccube4d-2.2-gcc41.patch b/games-puzzle/magiccube4d/files/magiccube4d-2.2-gcc41.patch
new file mode 100644
index 000000000000..adb4d2836a62
--- /dev/null
+++ b/games-puzzle/magiccube4d/files/magiccube4d-2.2-gcc41.patch
@@ -0,0 +1,22 @@
+--- EventHandler.h.old 2006-05-19 22:11:48.000000000 +0200
++++ EventHandler.h 2006-05-19 22:11:58.000000000 +0200
+@@ -165,7 +165,7 @@
+
+ int number_of_reference_stickers_needed;
+ int (*reference_stickers_needed)[4];
+- void (EventHandler::*what_to_do_after_got_reference_stickers) (void *arg = NULL);
++ void (EventHandler::*what_to_do_after_got_reference_stickers) (void *arg);
+ void* cur_ui_data;
+
+ bool quick_mode;
+--- Machine.h.old 2006-05-19 22:12:17.000000000 +0200
++++ Machine.h 2006-05-19 22:12:29.000000000 +0200
+@@ -31,7 +31,7 @@
+ {
+ public:
+ typedef void (EventHandler::*event_handler)(EventHandler::Event*,
+- void *arg = 0);
++ void *arg);
+ virtual ~Machine() {};
+
+ static Machine* createMachine(EventHandler*, int& argc, char *argv[],
diff --git a/games-puzzle/magiccube4d/files/magiccube4d-2.2-ldflags.patch b/games-puzzle/magiccube4d/files/magiccube4d-2.2-ldflags.patch
new file mode 100644
index 000000000000..446eb0cc91ae
--- /dev/null
+++ b/games-puzzle/magiccube4d/files/magiccube4d-2.2-ldflags.patch
@@ -0,0 +1,15 @@
+--- Makefile.in.old 2010-10-15 10:38:48.000000000 +0200
++++ Makefile.in 2010-10-15 10:39:07.000000000 +0200
+@@ -72,10 +72,10 @@
+ $(CXX) -c $(CXXFLAGS) $<
+
+ $(TARGET): $(OBJS)
+- $(CXX) -o $(TARGET) $(OBJS) $(LIBDIRS) $(LIBS)
++ $(CXX) $(LDFLAGS) -o $(TARGET) $(OBJS) $(LIBDIRS) $(LIBS)
+
+ $(TARGET).static: $(OBJS)
+- $(CXX) -static -o $(TARGET).static $(OBJS) $(LIBDIRS) $(LIBS)
++ $(CXX) $(LDFLAGS) -static -o $(TARGET).static $(OBJS) $(LIBDIRS) $(LIBS)
+
+ Vec.h: vec_h.c
+ $(CC) -o vec_h vec_h.c
diff --git a/games-puzzle/magiccube4d/files/magiccube4d-EventHandler.patch b/games-puzzle/magiccube4d/files/magiccube4d-EventHandler.patch
new file mode 100644
index 000000000000..7dae8981c4aa
--- /dev/null
+++ b/games-puzzle/magiccube4d/files/magiccube4d-EventHandler.patch
@@ -0,0 +1,11 @@
+--- EventHandler.cpp.old 2004-11-04 22:58:13.735812448 +1100
++++ EventHandler.cpp 2004-11-04 22:57:03.176539088 +1100
+@@ -326,7 +326,7 @@
+ number_of_reference_stickers_needed--;
+ reference_stickers_needed++;
+ if (number_of_reference_stickers_needed == 0)
+- (this->*what_to_do_after_got_reference_stickers)();
++ (this->*what_to_do_after_got_reference_stickers)(NULL);
+ }
+ }
+
diff --git a/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild b/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild
new file mode 100644
index 000000000000..f42d5a1d3fe6
--- /dev/null
+++ b/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+MY_PV=${PV/./_}
+DESCRIPTION="four-dimensional analog of Rubik's cube"
+HOMEPAGE="http://www.superliminal.com/cube/cube.htm"
+SRC_URI="http://www.superliminal.com/cube/mc4d-src-${MY_PV}.tgz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="x11-libs/libXaw"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}-src-${MY_PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-EventHandler.patch \
+ "${FILESDIR}/${P}"-gcc41.patch \
+ "${FILESDIR}/${P}"-64bit-ptr.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+ sed -i \
+ -e "s:-Werror::" \
+ configure \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake DFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dogamesbin magiccube4d
+ dodoc ChangeLog MagicCube4D-unix.txt readme-unix.txt Intro.txt
+ prepgamesdirs
+}
diff --git a/games-puzzle/magiccube4d/metadata.xml b/games-puzzle/magiccube4d/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/magiccube4d/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>